Question : 802.11ac - channel & config

Janusz Dziedzic janusz.dziedzic at gmail.com
Wed Jun 25 07:04:38 EDT 2014


2014-06-24 15:03 GMT+02:00 Charles Moulliard <ch007m at gmail.com>:
> I have installed iw 3.15 and done the modifications you proposed but that
> does not help at all as it can't find anymore the channel 48 now
>
Seems all 5GHz channels have (no IR).

What if you will up wlan iface and
iw reg set BE
iw reg get

You should get:
country BE: DFS-ETSI
 (2402 - 2482 @ 40), (N/A, 20)
 (5170 - 5250 @ 80), (N/A, 20)

and iw list should show channels 36-48 as available (without NO-IR).

> Here are the config + output trace + iw list :
> https://gist.github.com/cmoulliard/a246bc7c52240acbd309
>
> Question : As I would like to use the USB Wifi adapted as a Transmitter,
> which bps could I expect to have as the manufacturer claims that it should
> be 300mbps for USB2 and 867mbps for USB3 ?
>
This is theoretical maximum. Depends on many thing.

>
> On Tue, Jun 24, 2014 at 2:05 PM, Janusz Dziedzic <janusz.dziedzic at gmail.com>
> wrote:
>>
>> 2014-06-24 10:04 GMT+02:00 Charles Moulliard <ch007m at gmail.com>:
>> > Thx Janusz for your reply and your help.
>> >
>> > Here is more info collected based on your input. I have created a gist
>> > ticket with hostapd config, result to run the command 'iw list' and what
>> > is
>> > displayed in debug mode by hostapd -->
>> > https://gist.github.com/cmoulliard/17eba8ed42b81afb064d
>> >
>> > Remark : The new config does not work now and I don't get an error in
>> > the
>> > log
>> >
>>
>>            * 5230 MHz [46] (20.0 dBm) (passive scanning, no IBSS)
>>             * 5240 MHz [48] (20.0 dBm)
>>             * 5260 MHz [52] (20.0 dBm) (passive scanning, no IBSS,
>> radar detection)
>>
>> Seems using your HW you can setup AP only on channel 48 and only with
>> VHT20 - such HW limitation (btw you have old iw).
>> Seems DFS is also not supported.
>>
>> Change your config file:
>> #ieee80211h=1
>> #ieee80211d=1
>>
>> ht_capab=[SHORT-GI-20]
>> vht_oper_chwidth=0
>> vht_oper_centr_freq_seg0_idx=48
>>
>> You should get VHT20, with your 2 spacial streams you will have max tp
>> about 173Mbps (20MHz width and 2 spacial streams and SGI) - for 80211n
>> that was 144,4Mbps.
>>
>> To be sure connected station will use ht you can setup:
>> require_ht=1
>>
>> > Regards,
>> >
>> >
>> >
>> > On Tue, Jun 24, 2014 at 9:18 AM, Janusz Dziedzic
>> > <janusz.dziedzic at tieto.com>
>> > wrote:
>> >>
>> >> On 23 June 2014 13:09, Charles Moulliard <ch007m at gmail.com> wrote:
>> >> > Hi,
>> >> >
>> >> > Something goes wrong with my config of hostapd 2.2 on a linux kernel
>> >> > (3.14.7-200.fc20.x86_64). I have plugged an Edmix AC200 (WIFI USB)
>> >> > and
>> >> > it
>> >> > works fine using this driver
>> >> > (https://github.com/abperiasamy/rtl8812AU_8821AU_linux) and setup
>> >> > (hostapd
>> >> > 2.2 + dnsmaq) but I can't change the channel to a value higher than
>> >> > 48
>> >> > and
>> >> > bitrate is around 24Mbits/s (measured with iperf) between this
>> >> > machine
>> >> > and a
>> >> > client (=MacBook pro)
>> >> >
>> >> > What is the issue ?
>> >> >
>> >> 64 - is DFS channel, so required HW that support radar detection +
>> >> hostap config (country_code=, ieee80211d=1, ieee80211h=1)
>> >>
>> >> > sudo ./hostapd config_test.conf
>> >> > Configuration file: config_test.conf
>> >> > wlp0s20u2: IEEE 802.11 Configured channel (64) not found from the
>> >> > channel
>> >> > list of current mode (2) IEEE 802.11a
>> >> > wlp0s20u2: IEEE 802.11 Hardware does not support configured channel
>> >> > Could not select hw_mode and channel. (-3)
>> >> >
>> >> > More debug output available here :
>> >> > https://gist.github.com/cmoulliard/81aa9c7dc60c366f4724
>> >> >
>> >> > iwlist wlp0s20u2 channel
>> >> > wlp0s20u2  32 channels in total; available frequencies :
>> >> >           Channel 01 : 2.412 GHz
>> >> >           Channel 02 : 2.417 GHz
>> >> >           Channel 03 : 2.422 GHz
>> >> >           Channel 04 : 2.427 GHz
>> >> >           Channel 05 : 2.432 GHz
>> >> >           Channel 06 : 2.437 GHz
>> >> >           Channel 07 : 2.442 GHz
>> >> >           Channel 08 : 2.447 GHz
>> >> >           Channel 09 : 2.452 GHz
>> >> >           Channel 10 : 2.457 GHz
>> >> >           Channel 11 : 2.462 GHz
>> >> >           Channel 12 : 2.467 GHz
>> >> >           Channel 13 : 2.472 GHz
>> >> >           Channel 36 : 5.18 GHz
>> >> >           Channel 40 : 5.2 GHz
>> >> >           Channel 44 : 5.22 GHz
>> >> >           Channel 48 : 5.24 GHz
>> >> >           Channel 52 : 5.26 GHz
>> >> >           Channel 56 : 5.28 GHz
>> >> >           Channel 60 : 5.3 GHz
>> >> >           Channel 64 : 5.32 GHz
>> >> >           Channel 100 : 5.5 GHz
>> >> >           Channel 104 : 5.52 GHz
>> >> >           Channel 108 : 5.54 GHz
>> >> >           Channel 112 : 5.56 GHz
>> >> >           Channel 116 : 5.58 GHz
>> >> >           Channel 120 : 5.6 GHz
>> >> >           Channel 124 : 5.62 GHz
>> >> >           Channel 128 : 5.64 GHz
>> >> >           Channel 132 : 5.66 GHz
>> >> >           Channel 136 : 5.68 GHz
>> >> >           Channel 140 : 5.7 GHz
>> >> >           Current Frequency:5.24 GHz (Channel 48)
>> >> >
>> >> Please use iw list instead.
>> >>
>> >> > dabou at localhost Temp$ iwconfig
>> >> >
>> >> > wlp0s20u2  IEEE 802.11a  ESSID:"fuselab"  Nickname:"<WIFI at REALTEK>"
>> >> >           Mode:Master  Frequency:5.24 GHz  Access Point:
>> >> > D8:50:E6:F3:96:C7
>> >> >           Bit Rate:54 Mb/s   Sensitivity:0/0
>> >> >           Retry:off   RTS thr:off   Fragment thr:off
>> >> >           Power Management:off
>> >> >           Link Quality=66/100  Signal level=48/100  Noise level=0/100
>> >> >           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>> >> >           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>> >> >
>> >> > Config used :
>> >> >
>> >> > interface=wlp0s20u2
>> >> > ssid=fuselab
>> >> > #channel=48
>> >> > channel=64
>> >> >
>> >> > # WPA and WPA2 configuration
>> >> > macaddr_acl=0
>> >> > auth_algs=1
>> >> > ignore_broadcast_ssid=0
>> >> > wpa=3
>> >> > wpa_passphrase=fuselab987
>> >> > wpa_key_mgmt=WPA-PSK
>> >> > wpa_pairwise=TKIP
>> >> > rsn_pairwise=CCMP
>> >> >
>> >> > # Hardware configuration
>> >> > driver=nl80211
>> >> > wme_enabled=1
>> >> > ieee80211n=0
>> >> > ieee80211ac=1
>> >> > hw_mode=a
>> >> >
>> >> Here you can use (v)ht40/vht80 - as I remember correctly 80211ac=1
>> >> required also 80211n=1.
>> >>
>> >> BR
>> >> Janusz
>> >
>> >
>> >
>> >
>> > --
>> > Charles Moulliard
>> > Apache Committer / Architect @RedHat
>> > Twitter : @cmoulliard | Blog :  http://cmoulliard.github.io
>> >
>> >
>> > _______________________________________________
>> > HostAP mailing list
>> > HostAP at lists.shmoo.com
>> > http://lists.shmoo.com/mailman/listinfo/hostap
>> >
>>
>>
>>
>> --
>> Janusz Dziedzic
>
>
>
>
> --
> Charles Moulliard
> Apache Committer / Architect @RedHat
> Twitter : @cmoulliard | Blog :  http://cmoulliard.github.io
>



-- 
Janusz Dziedzic


More information about the HostAP mailing list