[PATCH] libnl: Document how to configure for libnl 2.0 and 3.2.

Dan Williams dcbw at redhat.com
Fri Jan 3 12:02:15 EST 2014


On Thu, 2014-01-02 at 14:32 -0800, greearb at candelatech.com wrote:
> From: Ben Greear <greearb at candelatech.com>
> 
> Reported-by: Xose Vazquez Perez <xose.vazquez at gmail.com>
> 
> Signed-hostap: Ben Greear <greearb at candelatech.com>
> ---
>  hostapd/defconfig        | 16 ++++++++++++++++
>  wpa_supplicant/defconfig | 16 ++++++++++++++++
>  2 files changed, 32 insertions(+)
> 
> diff --git a/hostapd/defconfig b/hostapd/defconfig
> index 2dd6fc8..7da7774 100644
> --- a/hostapd/defconfig
> +++ b/hostapd/defconfig
> @@ -22,6 +22,22 @@ CONFIG_DRIVER_HOSTAP=y
>  # Driver interface for drivers using the nl80211 kernel interface
>  CONFIG_DRIVER_NL80211=y
>  
> +# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be

I wouldn't say libnl 1.1 is "rather new" as it was released on
2008-1-14, almost 5 years ago.  libnl2 was released in late 2010 even.
If anything, libnl3 is "rather new" but the others are not...

Dan

> +# shipped with your distribution yet. If that is the case, you need to build
> +# newer libnl version and point the hostapd build to use it.
> +#
> +#LIBNLI=${FOO}/3plibs/libnl
> +#LIBNLL=${FOO}/server/local
> +#CFLAGS += -I$(LIBNLI)/include
> +#LIBS += -L$(LIBNLL)/lib
> +
> +# Use libnl v2.0 libraries.
> +#CONFIG_LIBNL20=y
> +
> +# Use libnl 3.2 libraries (if this is selected, CONFIG_LIBNL20 is ignored)
> +#CONFIG_LIBNL32=y
> +
> +
>  # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
>  #CONFIG_DRIVER_BSD=y
>  #CFLAGS += -I/usr/local/include
> diff --git a/wpa_supplicant/defconfig b/wpa_supplicant/defconfig
> index 0d2556d..e37dd8a 100644
> --- a/wpa_supplicant/defconfig
> +++ b/wpa_supplicant/defconfig
> @@ -88,6 +88,22 @@ CONFIG_DRIVER_WEXT=y
>  # Driver interface for Linux drivers using the nl80211 kernel interface
>  CONFIG_DRIVER_NL80211=y
>  
> +# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
> +# shipped with your distribution yet. If that is the case, you need to build
> +# newer libnl version and point the hostapd build to use it.
> +#
> +#LIBNLI=${FOO}/3plibs/libnl
> +#LIBNLL=${FOO}/server/local
> +#CFLAGS += -I$(LIBNLI)/include
> +#LIBS += -L$(LIBNLL)/lib
> +
> +# Use libnl v2.0 libraries.
> +#CONFIG_LIBNL20=y
> +
> +# Use libnl 3.2 libraries (if this is selected, CONFIG_LIBNL20 is ignored)
> +#CONFIG_LIBNL32=y
> +
> +
>  # Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
>  #CONFIG_DRIVER_BSD=y
>  #CFLAGS += -I/usr/local/include




More information about the HostAP mailing list