[PATCH 1/1] Fix hostapd and wpa_supplicant build with binutils >= 2.24.x

Jouni Malinen j at w1.fi
Wed Feb 19 08:21:41 EST 2014


On Mon, Feb 17, 2014 at 03:02:47PM -0400, Roger Zanoni wrote:
> Using binutils >= 2.24.x and setting
> CONFIG_WPA_TRACE/CONFIG_WPA_TRACE_BDF causes both builds to fail with
> "#error config.h must be included before this header" message.
> 
> Since version 2.24.x, the bfd header checks for PACKAGE and
> PACKAGE_VERSION macros.
> 
> As suggested in http://sourceware.org/bugzilla/show_bug.cgi?id=14243
> projects that use bfd and don't use autotools should define a PACKAGE
> macro.

Thanks, applied.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list