I always need a miracle to connect with iwlwifi

Felipe Contreras felipe.contreras at gmail.com
Mon Oct 28 02:24:20 EDT 2013


I already reported this problem [1] and I got no feedback whatsoever
at all. The issue keeps happening and I've tried many things.

First of all, when Linux is failing, my phone connects fine, other
computers connect fine, and this machine with Windows 7 as well. I've
tried reloading the driver, rebooting, different module parameters,
nothing works.

I logged a session [2] where I waited 30 minutes for the link to come
up, but it never did. You can see the same thing happening over and

1382936199.582861: nl80211: Association request send successfully
1382936199.797063: nl80211: Event message available
1382936199.797097: nl80211: Delete station e0:1d:3b:46:82:a0
1382936199.797881: nl80211: Event message available
1382936199.797905: nl80211: MLME event 38; timeout with e0:1d:3b:46:82:a0
1382936199.797915: wlan0: Event ASSOC_TIMED_OUT (15) received
1382936199.797920: wlan0: SME: Association timed out
1382936199.797924: Added BSSID e0:1d:3b:46:82:a0 into blacklist

If I reboot the router, it works immediately, another thing that works
is connecting with ad-hoc mode (mode=1), and then back to normal mode

Here's a log [3] where I tried reloading the module multiple times and
finally tried ad-hoc mode, after which the link came up.

Clearly the Linux kernel has a bug. Can somebody point out what needs
to be done to get this fixed?


[1] http://article.gmane.org/gmane.linux.kernel.wireless.general/108004
[2] http://people.freedesktop.org/~felipec/wpa/wpa-bad-30-min-wait.log
[3] http://people.freedesktop.org/~felipec/wpa/wpa-good-nothing-worked-except-mode-switch.log

Felipe Contreras

More information about the HostAP mailing list