Has anyone configure HostAPd nl80211 for Fedora 18

Dan Williams dcbw at redhat.com
Tue May 7 10:58:33 EDT 2013


On Tue, 2013-05-07 at 00:56 +0000, Naipaul Ojar wrote:
> Hi Dan,
> 
> I do have that file, and others also.
> 
> In the directory:-
> ../hostapd/hostapd-2.0/src/drivers/
> driver_common.o/.d
> driver_hostap.o/.d
> driver_nl802011.o/.d
> drivers.o/.d
> 
> I did a 'make clean' and while the required .o files are being generated, I am getting a link error when re-executing the 'make' command :-
> 
> 
>   ......
>   ......
>   CC  ../src/ap/hs20.c
>   CC  ../src/common/gas.c
>   CC  ../src/ap/gas_serv.c
>   CC  ../src/drivers/driver_common.c
> /bin/ld: cannot find -lnl-genl
> collect2: error: ld returned 1 exit status
> make: *** [hostapd] Error 1

Ok, when you see this error, please run:

make V=1

and the post the output.

Dan

> The current executable may not contain the nl80211 driver, and the linker fails against the library 'nl-genl'
> 
> http://rpmfind.net//linux/RPM/fedora/updates/18/x86_64/libnl3-3.2.21-1.fc18.i686.html
> libnl3-3.2.21-1.fc18 RPM for i686Provides
> libnl3
> config(libnl3)
> libnl-3.so.200
> libnl-genl-3.so.200
> libnl-nf-3.so.200
> libnl-route-3.so.200
> libnl3(x86-32)
> 
> 
> [ lib64]$ ls libnl*
> libnl-3.so           libnl-cli-3.so           libnl-genl-3.so           libnl-nf-3.so           libnl-route-3.so           libnl.so
> libnl-3.so.200       libnl-cli-3.so.200       libnl-genl-3.so.200       libnl-nf-3.so.200       libnl-route-3.so.200       libnl.so.1
> libnl-3.so.200.16.1  libnl-cli-3.so.200.16.1  libnl-genl-3.so.200.16.1  libnl-nf-3.so.200.16.1  libnl-route-3.so.200.16.1  libnl.so.1.1
> 
> #yum list libnl*
> Installed Packages
> libnl.x86_64                                   1.1-16.fc18                                                  @fedora 
> libnl-devel.x86_64                         1.1-16.fc18                                                  @fedora 
> libnl3.x86_64                                 3.2.21-1.fc18                                               @updates
> libnl3-cli.x86_64                             3.2.21-1.fc18                                                @updates
> libnl3-devel.x86_64                        3.2.21-1.fc18                                                @updates
> Available Packages
> libnl.i686                                        1.1-16.fc18                                                  fedora  
> libnl-devel.i686                              1.1-16.fc18                                                  fedora  
> libnl3.i686                                       3.2.21-1.fc18                                                updates 
> libnl3-cli.i686                                  3.2.21-1.fc18                                                updates 
> libnl3-devel.i686                             3.2.21-1.fc18                                                updates 
> libnl3-doc.x86_64                           3.2.21-1.fc18                                                updates 
> 
> Best Regards
> 
> Naipaul Ojar
>  
> 
>   ~~0~0~0~~
> 
> 
> > Subject: Re: Has anyone configure HostAPd nl80211 for Fedora 18
> > From: dcbw at redhat.com
> > To: naipaul_ojar at hotmail.com
> > CC: hostap at lists.shmoo.com
> > Date: Mon, 6 May 2013 17:32:27 -0500
> > 
> > On Mon, 2013-05-06 at 21:58 +0000, Naipaul Ojar wrote:
> > > I think, I have the config file correct ...
> > > 
> > > # hostapd ./hostapd-naipsHotSpot.conf 
> > > Configuration file: ./hostapd-naipsHotSpot.conf
> > > Line 5: invalid/unknown driver 'nl80211'
> > 
> > In your hostap build directory, do you have the file:
> > 
> > src/drivers/driver_nl80211.o
> > 
> > ?  If not, then something is going wrong with the build process, and
> > that driver isn't getting built.
> > 
> > Dan
> > 
> > 
> > > 1 errors found in configuration file './hostapd-naipsHotSpot.conf'
> > > [root at naipaulpc nojar ]# cat hostapd-naipsHotSpot.conf 
> > > #change wlan0 to your wireless device
> > > interface=wlan0
> > > #driver=iwlwifi
> > > #driver=cfg80211
> > > driver=nl80211
> > > ssid=naipsHotSpot
> > > channel=1
> > > 
> > > # ./myNetwork.sh 
> 
> > > wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
> > >         inet 192.168.0.66  netmask 255.255.255.0  broadcast 192.168.0.255
> > >         inet6 fe80::224:d7ff:fec6:5cdc  prefixlen 64  scopeid 0x20<link>
> > > 
> > > Best Regards
> > > 
> > > Naipaul Ojar.
> > >   ~~0~0~0~~
> > > 
> > > 
> > > > Subject: Re: Has anyone configure HostAPd nl80211 for Fedora 18
> > > > From: dcbw at redhat.com
> > > > To: naipaul_ojar at hotmail.com
> > > > CC: hostap at lists.shmoo.com
> > > > Date: Mon, 6 May 2013 16:49:34 -0500
> > > > 
> > > > On Mon, 2013-05-06 at 21:45 +0000, Naipaul Ojar wrote:
> > > > > I did post questions to the same thread, but no responses were provide to later threads. I do appologize for that.
> > > > > 
> > > > > Here is the results for the libnl3-devel.
> > > > > There are no results for libnl3-genl
> > > > 
> > > > You don't actually need a "libnl3-genl" because that library is included
> > > > in the libnl3-devel RPM that you've already go t installed.
> > > > 
> > > > So since I believe you  have everything required already, your build is
> > > > probably fine.  The last thing I said on that thread was:
> > > > 
> > > > ---
> > > > The appropriate hostap driver is "nl80211"
> > > > ---
> > > > 
> > > > Sorry if my reply wasn't clear enough, but what you want to do is use:
> > > > 
> > > > driver=nl80211
> > > > 
> > > > in your hostap config.  The hostap/wpa_supplicant "driver" for the
> > > > hardware you have is called "nl80211", not cfg80211 or iwlwifi.
> > > > 
> > > > Dan
> > > > 
> > > > > #yum install libnl3-devel
> > > > > Package libnl3-devel-3.2.21-1.fc18.x86_64 already installed and latest version
> > > > > Nothing to do
> > > > > 
> > > > > #rpm -qa | grep libnl | sort
> > > > > libnl-1.1-16.fc18.x86_64
> > > > > libnl3-3.2.21-1.fc18.x86_64
> > > > > libnl3-cli-3.2.21-1.fc18.x86_64
> > > > > libnl3-devel-3.2.21-1.fc18.x86_64
> > > > > libnl-devel-1.1-16.fc18.x86_64
> > > > > 
> > > > > 
> > > > > Best Regards
> > > > > 
> > > > > Naipaul Ojar
> > > > >  
> > > > > 
> > > > >   ~~0~0~0~~
> > > > > 
> > > > > 
> > > > > > Subject: Re: Has anyone configure HostAPd nl80211 for Fedora 18
> > > > > > From: dcbw at redhat.com
> > > > > > To: naipaul_ojar at hotmail.com
> > > > > > CC: hostap at lists.shmoo.com
> > > > > > Date: Mon, 6 May 2013 16:32:17 -0500
> > > > > > 
> > > > > > On Mon, 2013-05-06 at 21:13 +0000, Naipaul Ojar wrote:
> > > > > > > Thanks for posting the response.
> > > > > > > 
> > > > > > > I have taken this approach because I have been responding to the mailing list from 17-23 April and I still do not have an answer. The previous posting was titled :-
> > > > > > >     "Fedora 18, how do I get nl80211 or cfg80211 driver ?‏"
> > > > > > 
> > > > > > Then typically, you reply to the same discussion thread instead of
> > > > > > posting a new one, so that we have context from the discussion.  Then
> > > > > > I'd have known this was the same problem as before.
> > > > > > 
> > > > > > > The last status is:-
> > > > > > > >Hmm...i too faced the same issue. Installing the libnl-3.0 and
> > > > > > > >libnl-genl-3.0 resolved the issue
> > > > > > > >for me.I have 'libnl-3.0' but I have not been able to locate the 'libnl-genl-3.0' library.
> > > > > > 
> > > > > > yum install libnl3-devel
> > > > > > 
> > > > > > is what you need to get the appropriate libraries on Fedora.  That RPM
> > > > > > includes all the development headers and libraries needed to build
> > > > > > software that uses libnl version 3.  For Fedora, typically the
> > > > > > "development headers" packages are the same name as the master package,
> > > > > > plus "-devel" added to the name.
> > > > > > 
> > > > > > Dan
> > > > > > 
> 
>  		 	   		   		 	   		   		 	   		  




More information about the HostAP mailing list