about bit rate on 11b/g/n mode

bing_chou bing_chou at bandrich.com
Mon Jun 3 00:10:42 EDT 2013


Dear all

Some questions, please everybody help me, thanks

1.Why does the client's bit rate highest only show 54M (11g) , when I set wmm_enabled=0 on the AP?is this normal status?
2. why does it not change mode from 11n to 11 b/g , when I set wmm_enabled=1 and moved the client device that make the distance increased between the client and AP?
        How to change mode from 11n to 11b/g automatically?

Chip is AR9341
Wifi driver : ath9k
Hostapd:hostapd-20130302.tar.bz2
Openwrt version:
Beleeding_Edge:36267
feeds/package:36315

The hostapd.conf below

root at OpenWrt:/# cat /var/run/hostapd-phy0.conf
ctrl_interface=/var/run/hostapd-phy0
driver=nl80211
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
tx_queue_data3_aifs=7
tx_queue_data3_cwmin=15
tx_queue_data3_cwmax=1023
tx_queue_data3_burst=0
tx_queue_data2_aifs=3
tx_queue_data2_cwmin=15
tx_queue_data2_cwmax=63
tx_queue_data2_burst=0
tx_queue_data1_aifs=1
tx_queue_data1_cwmin=7
tx_queue_data1_cwmax=15
tx_queue_data1_burst=3.0
tx_queue_data0_aifs=1
tx_queue_data0_cwmin=3
tx_queue_data0_cwmax=7
tx_queue_data0_burst=1.5
hw_mode=g
channel=6

country_code=US


logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
ieee80211n=1
ht_capab=[HT20][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]
ieee80211d=1

interface=wlan0
ctrl_interface=/var/run/hostapd-phy0
disassoc_low_ack=1
preamble=1
auth_algs=1
wpa=0
ssid=OpenWrt_willis1
bridge=br-lan
wmm_enabled=0
bssid=00:03:7f:00:00:05
ignore_broadcast_ssid=0




More information about the HostAP mailing list