Could use some help with sw-crypt and ath10k.

Ben Greear greearb at candelatech.com
Wed Dec 11 15:04:35 EST 2013


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 12/11/2013 11:47 AM, Antonio Quartulli wrote:
> Hi Ben,
> 
> meanwhile somebody else gives his own feedback, I try to guess something..


- From looking a bit closer at some packet captures, it seems AP retries the EAPOL 3/4 quite a few
times and then gives up.

If I sniff the station (wlan2), I see the 3/4 and I see a 4/4 response,
but I guess that 4/4 never gets onto the air.

I do see the 2/4 from the client, but never a 4/4.  I do see a block-ack pkt from
the station when sniffing on the AP, after the 3/4 is sent.  Is there anything overly special
about the 4/4 packet that might cause it to not be transmitted properly?

I'll go dig into the firmware to see if I can notice anything interesting
there in the meantime.

Thanks,
Ben

- -- 
Ben Greear <greearb at candelatech.com>
Candela Technologies Inc  http://www.candelatech.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.13 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQEcBAEBAgAGBQJSqMVFAAoJELbHqkYeJT4OUC8H/RElFMxXPaVUQqWe1vshc+j+
/tK9eaN+ZVE5KDti+v5hQjrEY6peU6zBxA0AiUcHGrI2zrm9CKHMoO3xf1q7ARmb
EVBRQd77h51Yp/q1S//S4JGDBE3EJPZEq3c17xFVgni2QLBGxXPWfON2j7G1kxIZ
Nre115bYhiiy5snfe6hVG7B4U7AXgVft5M8v2t3Tj77RfcXtTPcoNH5VpVdnoYOk
zI/gayONp6KbNXaOjNNHVTfSfas7lMdjA7XiLUx7IdqQgeZlC8a4aEEzNh5rIZE7
Oxt3lqkSPuB21LWfp8jjUJd15WI4/7EzXXbAu4tINecUEcpcbXO+T5e9pDB6Y/I=
=XzT5
-----END PGP SIGNATURE-----


More information about the HostAP mailing list