Unable to set my channel with hostapd

Francisco Cuesta ndarkness at gmail.com
Mon Apr 29 04:27:19 EDT 2013


Hello,  thanks for replying,

I'm using ath9k driver in openwrt with hostapd v2.0-devel.

iw reg get
    (2412 - 2472 @ 40), (3, 27)
    (5170 - 5250 @ 40), (N/A, 31)
    (5250 - 5330 @ 40), (N/A, 31), DFS
    (5490 - 5600 @ 40), (N/A, 31), DFS
    (5650 - 5710 @ 40), (N/A, 31), DFS

iw list

Frequencies:
            * 5180 MHz [36] (17.0 dBm)
            * 5200 MHz [40] (21.0 dBm)
            * 5220 MHz [44] (17.0 dBm)
            * 5240 MHz [48] (17.0 dBm)
            * 5260 MHz [52] (17.0 dBm) (radar detection)
            * 5280 MHz [56] (17.0 dBm) (radar detection)
            * 5300 MHz [60] (17.0 dBm) (radar detection)
            * 5320 MHz [64] (17.0 dBm) (radar detection)
            * 5500 MHz [100] (17.0 dBm) (radar detection)
            * 5520 MHz [104] (21.0 dBm) (radar detection)
            * 5540 MHz [108] (21.0 dBm) (radar detection)
            * 5560 MHz [112] (21.0 dBm) (radar detection)
            * 5580 MHz [116] (21.0 dBm) (radar detection)
            * 5600 MHz [120] (disabled)
            * 5620 MHz [124] (disabled)
            * 5640 MHz [128] (disabled)
            * 5660 MHz [132] (17.0 dBm) (radar detection)
            * 5680 MHz [136] (17.0 dBm) (radar detection)
            * 5700 MHz [140] (17.0 dBm) (radar detection)
            * 5745 MHz [149] (21.0 dBm)
            * 5765 MHz [153] (21.0 dBm)
            * 5785 MHz [157] (21.0 dBm)
            * 5805 MHz [161] (21.0 dBm)
            * 5825 MHz [165] (20.0 dBm)
            * 4915 MHz [183] (21.0 dBm)
            * 4920 MHz [184] (21.0 dBm)
            * 4925 MHz [185] (21.0 dBm)
            * 4930 MHz [186] (21.0 dBm)
            * 4935 MHz [187] (21.0 dBm)
            * 4940 MHz [188] (21.0 dBm)
            * 4945 MHz [189] (21.0 dBm)
            * 4960 MHz [192] (21.0 dBm)
            * 4980 MHz [196] (21.0 dBm)



Configuration file: /var/run/hostapd-phy1.conf
wlan1: IEEE 802.11 Configured channel (165) not found from the channel
list of current mode (2) IEEE 802.11a
wlan1: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-4)
wlan1: Unable to setup interface.
Failed to start hostapd for phy1



hostapd conf file

root at OpenWrt:~# cat /var/run/hostapd-phy1.conf
ctrl_interface=/var/run/hostapd-phy1
driver=nl80211
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
tx_queue_data3_aifs=7
tx_queue_data3_cwmin=15
tx_queue_data3_cwmax=1023
tx_queue_data3_burst=0
tx_queue_data2_aifs=3
tx_queue_data2_cwmin=15
tx_queue_data2_cwmax=63
tx_queue_data2_burst=0
tx_queue_data1_aifs=1
tx_queue_data1_cwmin=7
tx_queue_data1_cwmax=15
tx_queue_data1_burst=3.0
tx_queue_data0_aifs=1
tx_queue_data0_cwmin=3
tx_queue_data0_cwmax=7
tx_queue_data0_burst=1.5
hw_mode=a
channel=165

country_code=US


logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
ieee80211n=1
ht_capab=[HT20][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]
ieee80211d=1
preamble=0

interface=wlan1
ctrl_interface=/var/run/hostapd-phy1
disassoc_low_ack=1
auth_algs=1
wpa=0
ssid=OpenWrt
bridge=br-lan
wmm_enabled=1
bssid=...
ignore_broadcast_ssid=0


But, could you explain me the reason behing I get this error, I mean,
what does it mean, for instance  problem with the interface, the
channel isn't supported by the driver ..., I would like to understand
it, not just resolve it.

Thanks in advance!

2013/4/27 Jouni Malinen <j at w1.fi>:
> On Sat, Apr 27, 2013 at 05:53:09PM +0200, Francisco Cuesta wrote:
>> I'm facing an issue with hostapd, I want to set some channel of 5Ghz
>> band (196 = 4980 MHz). However, am I always retreived the following
>> messege
>> Configured channel (196) not found from the channel list of current
>> mode (2) 802.11a"
>
> Which driver are you using? Which hostapd version? This seems to work at
> least with mac80211_hwsim.
>
>> But I don't know why I get this error whether the channel is available
>> on the driver (even  it is listed with iw phy1 list) and it is
>> supported bythe device. Why doesn't hostapd set it? What "channel
>> list" does it refert to?? What is more, I have disabled HTmode since I
>> though,that might be one of the reason of that error, but it turned
>> out that it wasn't...
>
> Could you please send the output of following commands?
>
> iw reg get
> iw list
> hostapd -dd your-config-file.conf
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap


More information about the HostAP mailing list