Error building eapol_test

Jouni Malinen j at w1.fi
Mon Nov 12 13:44:47 EST 2012


On Mon, Nov 12, 2012 at 05:48:14PM +0100, Rafael Díaz wrote:
> I'm trying to use eapol_test for testing a FreeRadius server I'm
> configuring. I've read everything and followed the steps to build it:
> 
> 1- Copy defconfig to .config
> 2- Uncomment CONFIG_EAPOL_TEST=y
> 3- Enter: make eapol_test
> 
> Then it starts building it and in the end this error message is shown:
> 
> /usr/bin/ld: cannot find -lnl

This is a library used by the nl80211 driver wrapper. You will either
need to install libnl development package or disable that driver wrapper
in the build (comment CONFIG_DRIVER_NL80211=y).

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list