SOLVED: Android ICS: wpa_supplicant not connecting to hostapd in 80211nmode

Valeriy Kucherenko darkside_ua at
Thu May 31 07:27:15 EDT 2012

Solved problem by compiling latest compat-wireless.

> I have made some investigation and found that disabling processing of WPA_STA_WMM flag in wpa_driver_nl80211_hapd_send_eapol(...) driver routine, 
> i.e. 
> int qos = 1; 
> allows my wireless client to authenticate with AP. 
> Now, instead of EAPOL 4-way handshake timeouts, I'm getting WPA: pairwise key handshake completed (RSN). 
> So, it looks like that this patch;a=commitdiff;h=4378fc14ebfb355705e7674bf347ea659bcd77bc won't work with my wpa_supplicant.
> But this is not solve my problem. After successful authentication client stuck at "receiving DHCP address" and then timeouts. And all this headache is only when AP in N-mode.
> Any suggestions where can I look next?
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the HostAP mailing list