HostAP compatibility settings

FreeBSD at nagilum.org FreeBSD at nagilum.org
Mon Jul 9 18:04:59 EDT 2012


Hi,
I'm trying to get my AP working - secure & usable. The AP is a net5501  
running FreeBSD 10.0-CURRENT (with the option of going to 9-STABLE).
The WLAN-HW is:
ath0: <Atheros 5416> mem 0xa0010000-0xa001ffff irq 10 at device 14.0 on pci0
ath0: [HT] enabling HT modes
ath0: [HT] RTS aggregates limited to 8 KiB
ath0: [HT] 2 RX streams; 2 TX streams
ath0: AR5416 mac 13.10 RF2133 phy 8.1
ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00d0

root at cakebox ~ > grep -e wlan -e hostap /etc/rc.conf
dhcpd_ifaces="vr1 vr2 wlan0"
hostapd_enable="YES"
hostapd_program="/usr/local/sbin/hostapd"
wlans_ath0="wlan0"
create_args_wlan0="wlanmode hostap -ampdutx 10.1.10.1/24"
ifconfig_wlan0="netmask 255.255.255.0 ssid room42 media autoselect up"

root at cakebox ~ > grep -v ^# /etc/hostapd.conf
interface=wlan0
debug=4
ctrl_interface=/var/run/hostapd
ctrl_interface_group=wheel
dump_file=/tmp/hostapd.dump
own_ip_addr=127.0.0.1
ieee8021x=0

ssid=reason42
macaddr_acl=0
auth_algs=1
wpa=3
wpa_passphrase=1234567890123456
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP TKIP

root at cakebox ~ > ifconfig wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
         ether b0:48:7a:bc:cb:c3
         inet 10.1.10.1 netmask 0xffffff00 broadcast 10.1.10.255
         inet6 fe80::b248:7aff:febc:cbc3%wlan0 prefixlen 64 scopeid 0x9
         nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
         media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>
         status: running
         ssid reason42 channel 6 (2437 MHz 11g ht/40+) bssid b0:48:7a:bc:cb:c3
         regdomain 32924 country CN indoor ecm authmode WPA1+WPA2/802.11i
         privacy MIXED deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit txpower 20
         scanvalid 60 protmode CTS -ampdutx ampdurx ampdulimit 64k
         ampdudensity 8 shortgi wme burst dtimperiod 1 -dfs

The real ssid & passphrase are different but similar. I'm running  
hostapd-1.0 from the ports.
So far I have had little luck associating with this AP. I have one  
ProBook6460b running Linux Mint12 that can associate with this AP but  
that's it. I have a Dreambox 8000, a Compaq6510b also Mint12 and a few  
WebOS devices - none of which can associate.
Here the log from the other Mint 12 machine since its the easiest to get to:
Kernel: 3.0.0-22-generic #34-Ubuntu SMP
Controller: 10:00.0 Network controller: Intel Corporation PRO/Wireless  
4965 AG or AGN [Kedron] Network Connection (rev 61)
dmesg shows this in a loop:
[ 2143.616607] cfg80211: Calling CRDA to update world regulatory domain
[ 2143.625431] cfg80211: Ignoring regulatory request Set by core since  
the driver uses its own custom regulatory domain
[ 2143.625441] cfg80211: World regulatory domain updated:
[ 2143.625447] cfg80211:     (start_freq - end_freq @ bandwidth),  
(max_antenna_gain, max_eirp)
[ 2143.625455] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz),  
(300 mBi, 2000 mBm)
[ 2143.625463] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz),  
(300 mBi, 2000 mBm)
[ 2143.625470] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz),  
(300 mBi, 2000 mBm)
[ 2143.625477] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz),  
(300 mBi, 2000 mBm)
[ 2143.625485] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz),  
(300 mBi, 2000 mBm)
[ 2145.850846] wlan0: authenticate with b0:48:7a:bc:cb:c3 (try 1)
[ 2145.853059] wlan0: authenticated
[ 2145.853357] wlan0: associate with b0:48:7a:bc:cb:c3 (try 1)
[ 2145.857300] wlan0: RX ReassocResp from b0:48:7a:bc:cb:c3  
(capab=0x431 status=0 aid=1)
[ 2145.857310] wlan0: associated
[ 2147.017589] wlan0: deauthenticating from b0:48:7a:bc:cb:c3 by local  
choice (reason=3)
[ 2147.028175] cfg80211: All devices are disconnected, going to  
restore regulatory settings
[ 2147.028182] cfg80211: Restoring regulatory settings
[ 2147.028186] cfg80211: Calling CRDA to update world regulatory domain

similar in syslog:
Jul  9 23:13:13 hplap kernel: [ 5963.048303] cfg80211: Calling CRDA to  
update world regulatory domain
Jul  9 23:13:13 hplap NetworkManager[564]: <info> (wlan0): supplicant  
interface state: 4-way handshake -> disconnected
Jul  9 23:13:13 hplap kernel: [ 5963.057875] cfg80211: Ignoring  
regulatory request Set by core since the driver uses its own custom  
regulatory domain

Jul  9 23:13:13 hplap kernel: [ 5963.057884] cfg80211: World  
regulatory domain updated:
Jul  9 23:13:13 hplap kernel: [ 5963.057889] cfg80211:     (start_freq  
- end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Jul  9 23:13:13 hplap kernel: [ 5963.057898] cfg80211:     (2402000  
KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul  9 23:13:13 hplap kernel: [ 5963.057905] cfg80211:     (2457000  
KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jul  9 23:13:13 hplap kernel: [ 5963.057913] cfg80211:     (2474000  
KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Jul  9 23:13:13 hplap kernel: [ 5963.057920] cfg80211:     (5170000  
KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul  9 23:13:13 hplap kernel: [ 5963.057927] cfg80211:     (5735000  
KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Jul  9 23:13:13 hplap NetworkManager[564]: <info> (wlan0): supplicant  
interface state: disconnected -> scanning
Jul  9 23:13:15 hplap wpa_supplicant[1162]: Trying to authenticate  
with b0:48:7a:bc:cb:c3 (SSID='room42' freq=2437 MHz)
Jul  9 23:13:15 hplap kernel: [ 5965.363511] wlan0: authenticate with  
b0:48:7a:bc:cb:c3 (try 1)
Jul  9 23:13:15 hplap wpa_supplicant[1162]: Trying to associate with  
b0:48:7a:bc:cb:c3 (SSID='room42' freq=2437 MHz)
Jul  9 23:13:15 hplap kernel: [ 5965.365580] wlan0: authenticated
Jul  9 23:13:15 hplap kernel: [ 5965.365851] wlan0: associate with  
b0:48:7a:bc:cb:c3 (try 1)
Jul  9 23:13:15 hplap NetworkManager[564]: <info> (wlan0): supplicant  
interface state: scanning -> associating
Jul  9 23:13:15 hplap kernel: [ 5965.369119] wlan0: RX ReassocResp  
from b0:48:7a:bc:cb:c3 (capab=0x431 status=0 aid=2)
Jul  9 23:13:15 hplap kernel: [ 5965.369128] wlan0: associated
Jul  9 23:13:15 hplap wpa_supplicant[1162]: Associated with b0:48:7a:bc:cb:c3
Jul  9 23:13:15 hplap NetworkManager[564]: <info> (wlan0): supplicant  
interface state: associating -> 4-way handshake
Jul  9 23:13:19 hplap kernel: [ 5969.376912] wlan0: deauthenticated  
from b0:48:7a:bc:cb:c3 (Reason: 2)
Jul  9 23:13:19 hplap wpa_supplicant[1162]: WPA: 4-Way Handshake  
failed - pre-shared key may be incorrect
Jul  9 23:13:19 hplap wpa_supplicant[1162]: CTRL-EVENT-DISCONNECTED  
bssid=b0:48:7a:bc:cb:c3 reason=2
Jul  9 23:13:19 hplap kernel: [ 5969.392855] cfg80211: All devices are  
disconnected, going to restore regulatory settings
Jul  9 23:13:19 hplap kernel: [ 5969.392867] cfg80211: Restoring  
regulatory settings
Jul  9 23:13:19 hplap kernel: [ 5969.392877] cfg80211: Calling CRDA to  
update world regulatory domain

On my AP I only see this in my syslog:
Jul  9 23:25:34 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: associated
Jul  9 23:25:38 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: disassociated
Jul  9 23:25:41 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: associated
Jul  9 23:25:45 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: disassociated
Jul  9 23:25:47 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: associated
Jul  9 23:25:51 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: disassociated
Jul  9 23:25:53 cakebox hostapd: wlan0: STA 00:1d:e0:aa:e4:97 IEEE  
802.11: associated
and so forth..
I can associate using Windows Vista so its not a HW issue.
I did some googling and tried giving station 00:1d:e0:aa:e4:97 a  
static IP but that didn't work.
In any case I'm looking for the problem on the AP side since none of  
the devices had any issues associating with any of the APs I was using  
before (some FritzBoxes and an EasyBox803).
Thanks for any suggestions.
Alex.


More information about the HostAP mailing list