[PATCH] build: allow overriding D-Bus version from pkg-config

Dan Williams dcbw at redhat.com
Wed Jan 4 18:12:11 EST 2012


On Wed, 2012-01-04 at 14:37 -0800, Grant Erickson wrote:
> This allows the package build to specify the D-Bus version being built
> against externally to pkg-config.

What does this actually do?  I don't see DBUS_VERSION actually used
anywhere in the wpa_supplicant code or makefiles, nor is it used in the
D-Bus headers.  Perhaps we should just remove those pieces?

Dan

> Signed-off-by: Grant Erickson <marathon96 at gmail.com>
> ---
>  wpa_supplicant/Makefile |    6 +++++-
>  1 files changed, 5 insertions(+), 1 deletions(-)
> 
> diff --git a/wpa_supplicant/Makefile b/wpa_supplicant/Makefile
> index 0832f10..554c22a 100644
> --- a/wpa_supplicant/Makefile
> +++ b/wpa_supplicant/Makefile
> @@ -1161,7 +1161,11 @@ endif
>  ifndef DBUS_INCLUDE
>  DBUS_INCLUDE := $(shell $(PKG_CONFIG) --cflags dbus-1)
>  endif
> -dbus_version=$(subst ., ,$(shell $(PKG_CONFIG) --modversion dbus-1))
> +ifndef DBUS_VERSION
> +dbus_version := $(subst ., ,$(shell $(PKG_CONFIG) --modversion dbus-1))
> +else
> +dbus_version := $(subst ., ,$(DBUS_VERSION))
> +endif
>  DBUS_VERSION_MAJOR=$(word 1,$(dbus_version))
>  DBUS_VERSION_MINOR=$(word 2,$(dbus_version))
>  ifeq ($(DBUS_VERSION_MAJOR),)




More information about the HostAP mailing list