Problems when using hostapd on meshnode

Kai Scharwies kai at scharwies.de
Wed Jan 4 03:42:06 EST 2012


2012/1/4 Yeoh Chun-Yeow <yeohchunyeow at gmail.com>:
> Hi, Kai
>
> Do you mind to share your "ifconfig" output? Are both ap0 and mesh0 using
> the same MAC addresses?
>
> Regards,
> Chun-Yeow
>

Hello Chun-Yeow,

before bringing the second interface up I change its MAC address using
ifconfig ap0 hw ether 00:0b:6b:02:11:57, which is used by no other
locally used card.
Here is my ifconfig output:

ifconfig mesh0
mesh0     Link encap:Ethernet  HWaddr 00:0b:6b:02:11:56
         inet addr:192.168.33.11  Bcast:192.168.33.255  Mask:255.255.255.0
         inet6 addr: fe80::20b:6bff:fe02:1156/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ifconfig ap0
ap0       Link encap:Ethernet  HWaddr 00:0b:6b:02:11:57
         inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::20b:6bff:fe02:1157/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Best regards,
Kai


More information about the HostAP mailing list