Recurring traffic/authentication freeze - detailed information (pt1)

Jouni Malinen j at w1.fi
Sat Feb 4 12:11:37 EST 2012


On Fri, Feb 03, 2012 at 02:44:06AM +0000, Bryan Phillippe wrote:

> However, it seems that when we have more than a dozen or so clients concurrently connected to any one AP, we begin to get strange traffic freezes where no traffic passes from the AP wireless interface to the bridged wired interface, and nobody can authenticate or associate with the AP during this time.  But, it looks like probe requests work and wired-only traffic is fine, and I can't see anything wrong from the shell (hostapd running, load under 1, no strange kernel messages, etc).  While the problem is occurring, it affects everyone at the same time - Windows, Mac, mobile clients, etc.  After a minute or so, the problem self-corrects for everyone.  If I kill and restart hostapd, the problem corrects right away.

> I have captured normal and debug logs + tcpdump output both during normal operation and during the problem, and would very much appreciate any help anyone would be willing to offer!

I did not notice any clear issues in the logs, but since the issue may
be some frames not getting transmitted or received properly, it would be
necessary to see what actually went out rather than what hostapd may
have tried to transmit. In other words, debugging this further is likely
to require using a separate wireless sniffer to capture the frames to
confirm what exactly is happening during the connectivity issue.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list