Recurring traffic/authentication freeze - detailed information (pt2)

Bryan Phillippe Bryan.Phillippe at watchguard.com
Thu Feb 2 21:47:25 EST 2012


I split this into two messages because the list apparently has a 25k message limit and the original with both healthy and abnormal traffic logs in one email pushed it just over the limit.

This message contains only the abnormal logs.  Part 1 contains the healthy logs.



Hello All,

First, I apologize for the size of this email, :-/  but I thank the experts - such as Jouni & Ben - in advance for reviewing it.

I have been trying to troubleshoot an extremely frustrating and difficult to debug (for me!) problem on our internal corporate APs.  These are a variety of CPU types, but all running the same software:

hostapd-0.7.3
compat-wireless-3.0-2
Linux-2.6.35.12

We are using the ath9k driver.

Generally, the setup works very well - fast and reliable.  However, it seems that when we have more than a dozen or so clients concurrently connected to any one AP, we begin to get strange traffic freezes where no traffic passes from the AP wireless interface to the bridged wired interface, and nobody can authenticate or associate with the AP during this time.  But, it looks like probe requests work and wired-only traffic is fine, and I can't see anything wrong from the shell (hostapd running, load under 1, no strange kernel messages, etc).  While the problem is occurring, it affects everyone at the same time - Windows, Mac, mobile clients, etc.  After a minute or so, the problem self-corrects for everyone.  If I kill and restart hostapd, the problem corrects right away.  I've also tried changing from WPA version 2 to WPA version 1, and even to open wireless, but the problem still happens in every case.



More information about the HostAP mailing list