wpa_supplicant not perform 4way handshake while using wpa-psk security

Vasanth Ragavendran ragavendra.2007 at gmail.com
Wed Feb 1 01:31:03 EST 2012


Thanks! the issue has been fixed.

On Wed, Feb 1, 2012 at 1:50 PM, Vasanth Ragavendran <
ragavendra.2007 at gmail.com> wrote:

> Some correction in the previous post.The end pc's can't be pingged since
> bridge is removed. however the ap and client are also not pinggable. Why is
> that so?
>
>
> ---------- Forwarded message ----------
> From: Vasanth Ragavendran <ragavendra.2007 at gmail.com>
> Date: Wed, Feb 1, 2012 at 1:16 PM
> Subject: Fwd: wpa_supplicant not perform 4way handshake while using
> wpa-psk security
> To: hostap at lists.shmoo.com
>
>
>
> >AP to start 4-way handshake - no such frame is visible in the debug log
>
> >you sent.
>
>
> Thank you so much for your reply Jouni. Yes it wasn't performing a 4-way handshake.
>
>
> >Could you please start by running the test without using the bridge
> >interface? I.e., remove ath0 from any bridge and remove that -b
> >parameter.
>
>
> I followed your suggestion and i've removed the wireless driver from the bridge as well as from the commandfor starting the supplicant, it was able to associate and the 4-way and group handshake are complete.    And the client and the AP are associated. However, I'm not able to ping between them! :( Neither am i able to ping the end pc's connected to the wireless devices. The connection setup is as follows.
>
> pc1 --- client --- ap --- pc2
>
> The link betn pc and the wireless devices are thru ethernet. How could this happen? Further, I am using ap and sta in wds mode. Where the mac address againt the "Access Point" is the mac address of the Ap which I'm connecting it to. However I even tried with an older version of wpa_supplicant and hostapd 0.5.9. Using that version, I'm able to associate and ping even if the wireless device(ath0) is bridged. What could be causing it to happen this way?! Thanks again for your help. Awaiting your early response. Attached please find the log of the successfully completed handshake, but unable to ping the ap from the client or ping the client from the ap.
>
>
> Thanks and Regards
> R.Vasanth Ragavendran.
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20120201/c0bb1d99/attachment-0001.htm 


More information about the HostAP mailing list