WPS problems after updating hostapd

Jouni Malinen j at w1.fi
Sun Dec 23 05:08:38 EST 2012


On Thu, Dec 13, 2012 at 03:29:12PM +0100, Sven Neumann wrote:
> we are having problems to perform WPS between a Linux host running Linux
> 3.4.16 and hostapd 1.0 using an ath5k card and a Linux client running
> Linux 3.0.4 and wpa_supplicant 1.0 using a Marvell Libertas SD8686
> module. We have done WPS successfully on these devices before using
> hostapd 0.7.3. But now I've tried to update hostapd and WPS stopped
> working with both version 1.0 and 1.1.

Can you confirm that the exact same setup works if you just replace
hostapd version (i.e., same driver and kernel on the AP but different
hostapd version)?

> It would be very helpful if someone with more clue about these things
> than me could have a look at the logs and/or perhaps give me some
> pointers on what I could do to shed some more light on this.

wpa_supplicant log claims that an EAPOL-Start frame is being sent while
hostapd log claims that no such frame is received.. Because of this, WPS
1.0 connection is not allowed to continue (WPS 2.0 would allow that, but
it does not look like you included CONFIG_WPS2=y in .config for at least
one of the ends). Anyway, the real issue is in EAPOL packet from station
to the AP not getting through for some reason.

It could be useful to verify with a wireless sniffer that the EAPOL
packet from the station is indeed transmitted (and acknowledged by the
AP) and if that is the case, try to figure out where that gets lost on
the AP side.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list