Disconnected clients from a running hostapd on a bridged interface

Jouni Malinen j at w1.fi
Wed Oct 5 14:32:25 EDT 2011


On Wed, Oct 05, 2011 at 03:55:22PM +0200, Simon Morgenthaler wrote:

> The output (with hostapd -d) after a connection and disconnection with the 
> android smartphone looks like that:

> association request: STA=38:e7:d8:xx:xx:xx capab_info=0x421 listen_interval=10
>   new AID 1
> wlan0: STA 38:e7:d8:xx:xx:xx IEEE 802.11: association OK (aid 1)
> mgmt::assoc_resp cb
> wlan0: STA 38:e7:d8:xx:xx:xx IEEE 802.11: associated (aid 1)
> wlan0: AP-STA-CONNECTED 38:e7:d8:xx:xx:xx
> wlan0: STA 38:e7:d8:xx:xx:xx MLME: MLME-
> ASSOCIATE.indication(38:e7:d8:xx:xx:xx)
> wlan0: STA 38:e7:d8:xx:xx:xx MLME: MLME-DELETEKEYS.request(38:e7:d8:xx:xx:xx)
> wlan0: STA 38:e7:d8:xx:xx:xx RADIUS: starting accounting session 
> 000034EE-00000000
> IEEE 802.1X: Ignore STA - 802.1X not enabled or forced for WPS
> nl80211: Event message available
> nl80211: New station 38:e7:d8:xx:xx:xx
> 
> mgmt::disassoc
> disassocation: STA=38:e7:d8:xx:xx:xx reason_code=8
> wlan0: AP-STA-DISCONNECTED 38:e7:d8:xx:xx:xx

It looks like the station decided to disconnect (reason code 8 is
"Disassociated because sending STA is leaving BSS") for some reason.
Consequently, there is not really much you could see from hostapd debug
log and the real information would be on the station.. The best option
would be to debug the station, but if that is not feasible with the
specific devices that show this issue, the next best option would be to
take a look at a wireless sniffer log showing all the frames exchanged
between the station and the AP. Since the station seems to be leaving in
5-60 seconds, my first guess would be that some operation like DHCP
times out and makes the station leave the network.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list