about the openssl in the EAP-FAST

why why1988seu at 126.com
Thu Nov 3 05:19:40 EDT 2011


This is my hostap_fast.conf:
interface=wlan0
bridge=br0
driver=nl80211
ssid=FAST
hw_mode=g
channel=6
auth_algs=1
ieee8021x=1
eapol_version=1
eap_server=1
eap_user_file=/home/wlan/wlan/hostapd-0.7.3/hostapd/hostapd.eap_user
ca_cert=/home/wlan/wlan/hostapd-0.7.3/hostapd/newcerts/cacert.pem
server_cert=/home/wlan/wlan/hostapd-0.7.3/hostapd/newcerts/APcert.pem
private_key=/home/wlan/wlan/hostapd-0.7.3/hostapd/newcerts/APkey.pem
private_key_passwd=wlan
#dh_file=/home/wlan/wlan/hostapd-0.7.3/hostapd/newcerts/hostapd.dh.pem
pac_opaque_encr_key=000102030405060708090a0b0c0d0e0f
eap_fast_a_id=101112131415161718191a1b1c1d1e1f
eap_fast_prov=3
pac_key_lifetime=604800
pac_key_refresh_time=86400
wpa=1
wpa_key_mgmt=WPA-EAP
wpa_pairwise=TKIP
 
The openssl give errors:
OpenSSL: tls_global_client_cert - Failed to load client certificate error:0D07207B:asn1 encoding routines:ASN1_get_object:header too long
OpenSSL: pending error: error:140AD00D:SSL routines:SSL_CTX_use_certificate_file:ASN1 lib
OpenSSL: pending error: error:0906D06C:PEM routines:PEM_read_bio:no start line
OpenSSL: pending error: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib
Failed to set TLS parameters
 
What is wrong? Thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20111103/3b5255d5/attachment.htm 


More information about the HostAP mailing list