AP in WEP mode configuration

Liketo talk foreverfrnd at gmail.com
Wed May 25 12:10:58 EDT 2011


Hi,
Thanks for the reply. I did this all but I am unable to get WEP to work. The
supplicant never  issues the WEP keys to the driver. Am I missing anything
here? Any pointers would be appreciated!

On Tue, May 24, 2011 at 1:23 PM, <Piotr.Nakraszewicz at tieto.com> wrote:

> Hi,
>
> To start a network in AP mode your driver has to support it, you need to
> set CONFIG_AP=y in .config and you need to add two parameters to your
> network configuration:
> mode=2
> frequency=(e.g. 2412)
>
> Best regards,
>
> Piotr Nakraszewicz
>
> From: hostap-bounces at lists.shmoo.com [mailto:
> hostap-bounces at lists.shmoo.com] On Behalf Of Liketo talk
> Sent: 23 maja 2011 18:12
> To: hostap at lists.shmoo.com
> Subject: AP in WEP mode configuration
>
>
> Hi,
>
> I was trying to setup an AP in WEP mode by using the wpa_supplicant. The
> following is the configuration that I have specified. However, strangely
> this configuration info is not given to the driver at all after I start the
> supplicant. Does anyone know anything that I am missing here? Which file
> handles parsing and setting the key in the supplicant source code?
>
> network={
>   ssid="xxx"
>   key_mgmt=NONE
>   wep_key0=0123456789abcdef0123456789
>   wep_tx_keyidx=0
>  }
> Regards.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20110525/5a7ced86/attachment.htm 


More information about the HostAP mailing list