Testing Auto Channel Selection with hostapd in ath5k and ath9k

Swaminathan Vasanth Rajaraman swaminathanvasanth.r at gmail.com
Mon Jul 18 05:12:27 EDT 2011


Hi,

 I was able to fix the previous issue where i mentioned i was not able to
enable ACS in hostapd, now i am able to enable ACS algorithm, but got a new
issue :
 After building hostapd with ACS, i configured hostapd.conf file with
channel = acs_survey and acs_num_req_surveys=10, acs_roc_duration_ms=5.

rajaras1 at kesateekkari:/etc/hostapd$ sudo hostapd hostapd.conf
Configuration file: hostapd.conf
ACS: automatic channel selection started, this may take a bit
ACS: offchannel TX support required
Segmentation fault

Even now without ACS, its working fine now.
Any one who has ACS enabled in hostapd please help in this issue.

Thanks,


On Mon, Jul 18, 2011 at 11:25 AM, Swaminathan Vasanth Rajaraman <
swaminathanvasanth.r at gmail.com> wrote:

> Hi,
>
>  Kindly please take a look at this e mail and guide me on where to look at
> for fixing this Auto Channel Selection issue.
>
> ---------- Forwarded message ----------
> From: Swaminathan Vasanth Rajaraman <swaminathanvasanth.r at gmail.com>
> Date: Fri, Jul 15, 2011 at 1:45 PM
> Subject: Fwd: Testing Auto Channel Selection with hostapd in ath5k and
> ath9k
> To: ath9k-devel <ath9k-devel at lists.ath9k.org>
>
>
>
> Hi,
>  Any one working on hostapd please help in this issue. Did not get a reply
> from hostap mailing list, so just posting here and trying my luck to get
> some guidance.
>
>
> Hi,
>
>  I am trying to enable the Auto Channel Selection in hostapd with ath5k and
> ath9k drivers. I cloned the source of hostap from the git and applied the
> patch (
> http://www.kernel.org/pub/linux/kernel/people/mcgrof/patches/hostapd/acs-all-in-one-v2.patch). I then went to the hostapd directory of hostap and did make and make
> install. Followed instruction from (
> http://wireless.kernel.org/en/users/Documentation/hostapd#Download_and_compile_hostapd).
>
> While building the software i enabled CONFIG_ACS=y in  the defconfig file
> present in /hostap/hostapd/ to .config and performed the build. I then did a
> make install and configured the hostapd.conf file.
>
> Hostapd is working fine for me without ACS but when i enable channel=0 or
> channel=acs_survey and uncomment the
>
> acs_num_req_surveys=10
> acs_roc_duration_ms=5
>
> options for ACS to be enabled it throws this error when starting hostapd,
>
>
> > sudo hostapd hostapd.conf
>
> Configuration file: hostapd.conf
> Line 113: set as '0' tries to enable ACS but CONFIG_ACS disabled
> Line 125: invalid acs_num_req_surveys 10 (CONFIG_ACS disabled)
> Line 126: invalid acs_roc_duration_ms 5 (CONFIG_ACS disabled)1..5000)
> 3 errors found in configuration file 'hostapd.conf'
>
> Infact i enabled CONFIG_ACS when building.
>
>
> Any pointers on what to do to enable ACS please.
>
> Awaiting your kind reply.
>
> Thanks,
>
> --
> Best Regards,
> Swaminathan Vasanth Rajaraman
>
>
>
> --
> Best Regards,
> Swaminathan Vasanth Rajaraman
>
>
>
> --
> Best Regards,
> Swaminathan Vasanth Rajaraman
>



-- 
Best Regards,
Swaminathan Vasanth Rajaraman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20110718/ffa6e235/attachment.htm 


More information about the HostAP mailing list