No beacon activity

Lara Deek laradeek at cs.ucsb.edu
Fri Feb 11 20:32:27 EST 2011


Hi,

I was able to figure out one of my problems. The devices in master mode
using hostapd now transmit periodic beacon messages. I followed the
directions of setting up hostapd to the dot, and that worked out. I am not
sure which part made the difference. Here are the links for whomever might
have the same problem: http://acx100.erley.org/stable.html,
http://www.robert-heyward.com/rjh/?page_id=12

However, I still have the problem that the sniffer (monitor interface)
running on the same device that is running hostapd in master mode does not
capture beacon messages. I had two devices, with the same hostapd
configuration and PC card, run on the same channel, and they wouldn't
capture each others beacon messages. I had another device with a different
PC card run in monitor mode, and it did receive beacon messages from the
mentioned two devices.

I then ran one of the devices with only a monitoring interface, and it was
able to capture beacon messages from the other. Why is it that the monitor
interface stops capturing beacon messages when hostapd (i.e. another
interface in master/AP mode) is running on the same machine?

I would greatly appreciate any insight.

Thank you for your time,
Lara


On Wed, Feb 9, 2011 at 3:19 PM, Lara Deek <laradeek at cs.ucsb.edu> wrote:

>
> Thank you for your reply Jouni.
>
>
>> Date: Sun, 6 Feb 2011 13:13:12 +0200
>> From: Jouni Malinen <j at w1.fi>
>> Subject: Re: No beacon activity
>> To: hostap at lists.shmoo.com
>>
>>
>> On Thu, Feb 03, 2011 at 10:53:50AM -0800, Lara Deek wrote:
>> > 1) I am running a sniffer on the same machine A that is running hostapd.
>> The
>> > sniffer does not capture beacon messages (only captures probe request
>> and
>> > response packets, both broadcast and unicast). I ran a sniffer from
>> another
>> > machine B (with a different card) in monitor mode, and B does in fact
>> > capture beacon messages (but never from A). Is there any reason why I do
>> not
>> > sniff beacon frames on A? How can I fix this?
>>
>> The actual Beacon frame transmission is not done by mac80211 and there
>> is no mechanism for the driver to indicate that a Beacon frame was
>> transmitted since this is not normally needed for anything. What would
>> you be using the Beacon frames for in the local sniffer?
>>
>>
> The beacons I would like machine A to capture are those of its neighboring
> APs, to identify which APs can potentially conflict with it if they are on
> the same channel. A does not capture any beacons, but only captures probe
> request (broadcast) and response messages.
>
>
>
>> > 2) I understand that hostapd only configures mac80211 with a template
>> and
>> > beacon interval, but does not actually send beacons. Is enabling beacon
>> > transmission related to the firmware or driver? I have an AirMagnet
>> C1060 PC
>> > card with an an Atheros, ath9k support, chipset that is not sending
>> beacon
>> > messages. How should enable beacon transmission?
>>
>> The driver is responsible for configuring Beacon frame transmissions.
>>
>> How exactly did you verify that the card is not sending out Beacon
>> frames? Have you used another device in monitor mode to check that?
>>
>>
> Yes, I have used another device in monitor mode (with an Ubiquiti SRC
> 802.11a/b/g MCX card with an AR5004 chipset), which captures beacons from
> sources but never from A. A has an AirMagnet card<http://www.airmagnet.com/assets/AirMagnet_802.11abgn_WirelessPCcard_TechSpec.pdf>which has an AR5416+AR5133 ath9k supported chipset. I am not sure whether
> the issues I am facing are actually due to limitations of the 802.11n PC
> card I am using. Unfortunately, the card has no online support.
>
> Otherwise, I am correctly configuring hostapd on A to run in master mode.
> After running hostapd, running iwconfig on A indicates that it is in master
> mode. The only problem is that there is no beacon activity. I would
> appreciate any insight on what the problem could be.
>
> Thank you,
> Lara
>
>
>
>> --
>> Jouni Malinen                                            PGP id EFC895FA
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20110211/646918b9/attachment.htm 


More information about the HostAP mailing list