wpa_supplicant: Processing P2P Service Discovery Externally

윤민홍 mhyun at etri.re.kr
Tue Dec 20 21:32:37 EST 2011


Dear colleagues,

 

I’m trying to process P2P Service Discovery request with external program.

I tested some P2P commands, however a problem blocked me to go further.

 

The experimental environment is:

wlan0 (02:00:00:00:00:00): processing P2P Service Discovery request EXTERNALLY & wpa_cli

wlan1 (02:00:00:00:01:00): wpa_cli

 

The testing procedure is:

1.     wlan1 sent a P2P SD request to wlan0.
I typed “p2p_serv_disc_req 02:00:00:00:00:00 02000001” in wpa_cli of wlan1.

2.     wpa_cli of wlan0 displayed P2P SD request from wlan1.
The displayed messages is “<3>P2P-SERV-DISC-REQ 2437 02:00:00:00:01:00 0 0 02000001”

3.     To respond the request I typed “p2p_serv_disc_resp 2437 02:00:00:00:01:00 0 0300000101” in wpa_cli of wlan0. And, “OK” showed up in wpa_cli.

4.     I expected that wpa_cli of wlan1 displayed “<3>P2P-SERV-DISC-RESP 02:00:00:00:00:00 0 0300000101”, however no message was displayed.
Also, wpa_cli of wlan0 displayed “<3>P2P-SERV-DISC-REQ 2437 02:00:00:00:01:00 0 0 02000001” multiple times until I cancel the SD request on wlan1.

 

When I tested the same thing with dbus API, same result occurred.

Please let me know in which part I made a mistake.

 

Best Regards,

 

Minhong Yun

------------------------------------------------------

Software Research Laboratory, ETRI

Tel: +82-42-860-6394 / Fax: +82-42-860-6671

Minhong Yun

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20111221/a9a9960e/attachment.htm 


More information about the HostAP mailing list