[ath9k-devel] DWA-556 not working as AP

sami ahokas sami.m.ahokas at gmail.com
Fri Aug 19 08:13:26 EDT 2011


2011/8/11 Pavel Roskin <proski at gnu.org>:
> On Wed, 10 Aug 2011 09:30:27 +0300
> sami ahokas <sami.m.ahokas at gmail.com> wrote:
>
>> Thanks again for your help. But now I have next problem and quick
>> googling didn't give me any answers. Here is what I get from hostapd:
>>
>> ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
>
> It looks like you are using some different driver on ath0.  Run
>
> readlink /sys/class/net/ath0/device/driver
>
>> ath0: DRIVER Error enabling WPA/802.1X!
>> IEEE 802.1X initialization failed.
>> ath0: Unable to setup interface.
>> rmdir[ctrl_interface]: No such file or directory
>>
>> Why is it complaining about 802.1X? My setup is using WPA-PSK, not
>> 802.1X. Do I miss some modules or have I compiled hostapd or madwifi
>> driver with wrong parameters?
>
> The message comes from driver_madwifi.c and can be easily improved, but
> I don't see much point in that.  WPA was mentioned after all.
>
> --
> Regards,
> Pavel Roskin
>

Hi,

I'm still struggling with this. I'm back to using ath9k driver. I have
several DWA-556 cards of which some works just fine, but some of them
are awful. I have enabled all possible debug features for ath9k driver
and I have noticed that there are a lot of GTT interrupts on those bad
boards. Can someone tell me what those interrupts are?

Also, with bad boards I get lot of following log messages:

kernel: ath: Reset ANI state opmode 3
kernel: ath: ANI parameters:
kernel: ath: ANI parameters:
kernel: ath: Reset ANI state opmode 3
kernel: ath: ANI parameters:
kernel: ath: ANI parameters:

What are those about?

regards,
Sami


More information about the HostAP mailing list