[ath9k-devel] DWA-556 not working as AP

sami ahokas sami.m.ahokas at gmail.com
Wed Aug 10 07:41:53 EDT 2011


2011/8/10 sami ahokas <sami.m.ahokas at gmail.com>:
> 2011/8/9 Pavel Roskin <proski at gnu.org>:
>> Quoting sami ahokas <sami.m.ahokas at gmail.com>:
>>
>>> Thanks for your reply. I chose to try the MadWifi driver, but now I'm
>>> not able to set interface to master mode.
>>
>> When loading the module, use "modprobe ath_pci autocreate=ap"
>>
>> That will create an interface in AP mode.  It's easy to get used to the
>> niceties of the kernel drivers that can change the mode of an existing
>> interface.
>>
>> --
>> Regards,
>> Pavel Roskin
>>
>
> Thanks again for your help. But now I have next problem and quick
> googling didn't give me any answers. Here is what I get from hostapd:
>
> ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
> ath0: DRIVER Error enabling WPA/802.1X!
> IEEE 802.1X initialization failed.
> ath0: Unable to setup interface.
> rmdir[ctrl_interface]: No such file or directory
>
> Why is it complaining about 802.1X? My setup is using WPA-PSK, not
> 802.1X. Do I miss some modules or have I compiled hostapd or madwifi
> driver with wrong parameters?
>
> Sami
>

I got that one fixed myself. Some of the kernel modules wasn't copied
to my target and therefore those errors. So I finally got hostapd
running but I got lot of messages about Stuck beacon:

wifi0: ath_bstuck_tasklet: Stuck beacon; resetting (beacon miss count: 11)

Have I understand correctly that this is a persistent bug that no one
has managed to solve? At least at madwifi project page there is a
story about stuck beacon problem that seems to be open.

Sami


More information about the HostAP mailing list