[PATCH] fix rogue disconnect issues w/WPA2 Enterprise networks

Dan Williams dcbw at redhat.com
Wed Sep 22 11:46:32 EDT 2010


On Wed, 2010-09-22 at 09:54 +0200, Hendrik Beijeman wrote:
> >
> > That's clearly not the right fix though, since disconnect events are a
> > normal part of life.  This smells more like a driver problem...  Can you
> > get driver debugging at all?
> I suppose i could get some driver (wext, iwlagn) debug. However, I've
> connected to numerous APs without any problem at all, though these were
> simple WPA-personal networks. The one that gives me all the grief is a
> complicated one; WPA2 enterprise, AES, PEAP/MSCHAPv2. I can easily
> verify & reproduce that this patch makes the connection stable again.
> 
> The driver receives SIOCGIWAP (get AP mac), and when it turns out to be
> 0 it disassociates, even though its already associated to another AP?
> 
> Any pointers where I can look for more information to understand whats
> going on?

Any time wpa_supplicant receives a "disconnect" event that means the
driver has terminated association or authentication with the AP.  That
could be an error in the driver (it didn't receive beacons from the AP
for some reason, or its not operating correctly and it *thinks* it
terminated association wtih the AP) or it could be that the AP
terminated association with your wireless card and the driver is simply
reporting that state.  We need to figure out which one and why.  For
starters, can you paste in some of the "dmesg" output when this happens?
There's usually some manner of debugging info there.

Dan



More information about the HostAP mailing list