hostapd 0.7.2 segmentation fault

Jouni Malinen j at w1.fi
Sun Sep 5 05:50:21 EDT 2010


On Wed, May 26, 2010 at 04:34:55PM +0900, Alan wrote:

> I get a segmentation fault every time I try to run hostapd version
> 0.7.2.  Version 0.6.10 works fine.

> driver=madwifi
> ieee80211n=1
> ht_capab=[HT40-][SHORT-GI-40][DSSS_CCK-40][AMPDU]

madwifi does not use ieee80211n parameters from hostapd and this
combination resulted in the segmentation fault. This is now fixed in the
development branch and as a quick workaround, you can just remove that
ieee80211n=1 line from hostapd.conf.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list