wpa_supplicant and ifplugd combination not working

J. Bakshi joydeep at infoservices.in
Fri Sep 3 06:25:42 EDT 2010


Hello list,

I am using wpa_supplicant in debian squeeze. I am using mapping in /etc/network/interfaces as I am using guessnet and the setting is working perfectly well. Here is my configuration

```````````````````````````````````
mapping wlan0
     script guessnet-ifupdown
     map default: office-wifi
     map  office-wifi open unknown
     map timeout: 12
     # map init-time: 12   # for slow drivers
     map verbose: true
     map debug: true

 iface office-wifi inet static
        test wireless  mac  00:1C:F0:3D:4C:C9
        address 192.168.1.199
        netmask 255.255.0.0
        network 192.168.1.0
        broadcast 192.168.1.0
        gateway 192.168.1.1
        wpa-driver wext
        wpa-ssid "xxxxxxxxxx"
        wpa-psk 026d1e67ce2899210d81f4af99cdd
        wpa-key-mgmt WPA-PSK
        # scan hidden SSID
        wpa-ap-scan 2
        #"RSN" = WPA(2)
        wpa-proto RSN
        #encryption
        #"CCMP" = AES cipher as part of WPA(2) standard.
        #"TKIP" = TKIP cipher as part of WPA(1) standard.
        wpa-pairwise CCMP
        wpa-group CCMP

............ more mappings.........
..................................

``````````````````````````````

So when I run "ifup wlan0" guessnet scan through all the mappings and whenever it finds a match , it correctly configures the wifi. To do the wifi configuration automatic , I have installed ifplugd and the configuration is 

```````````````````
INTERFACES="eth0 wlan0"
HOTPLUG_INTERFACES=""
#ARGS="-q -f -u0 -d10 -w -I"
ARGS="-f -u0 -d10 -w -I"
USPEND_ACTION="stop"
``````````````````````

BUT it never works here. Though a lots of online tutorial mention that ifplugd and wpa_supplicant can automatically up the wifi based on the access point detection. Have I missed something ?  Please suggest.

Thanks


More information about the HostAP mailing list