Cannot connect to Deutsche Telekom Speedport with WPA

Stephen Bosch posting at vodacomm.ca
Fri Nov 26 13:55:56 EST 2010


Hi, all:

We had been using a Fritzbox 7010 until recently, but it died. In the
interim, we are using a Speedport from Deutsche Telekom.

My connection to the Fritzbox worked fine.

I cannot connect to the Speedport, and I am the only person in the house for
whom it does not work (we have Windows XP and MacOS users).

I have been looking at the output of wpa_supplicant for hours, and cannot
make heads or tails of it.

The command:

> wpa_supplicant -ddddt -ctest.conf -ieth1 -Dwext 2&> out.log


output of iwconfig (when trying to associate it will show the ESSID
correctly but always says "Not-Associated").


> eth1      unassociated  ESSID:off/any  Nickname:"ipw2100"
>           Mode:Managed  Channel=0  Access Point: Not-Associated
>           Bit Rate:0 kb/s   Tx-Power:16 dBm
>           Retry short limit:7   RTS thr:off   Fragment thr:off
>           Encryption key:5350-2D58-3955-3044-3534-3772   Security mode:open
>           Power Management:off
>           Link Quality:0  Signal level:0  Noise level:0
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:18   Missed beacon:0


Things I noticed:


> 1290757247.814007: Association request to the driver failed


Unfortunately, it doesn't tell me why.


> 1290757258.494384: EAPOL: External notification - EAP success=0
> 1290757258.494392: EAPOL: Supplicant port status: Unauthorized
> 1290757258.494401: EAPOL: External notification - EAP fail=0
>

Neither success, nor failure?


> 1290757258.494406: EAPOL: Supplicant port status: Unauthorized
> 1290757258.494412: EAPOL: External notification - portControl=Auto
> 1290757258.494416: EAPOL: Supplicant port status: Unauthorized

1290757258.494512: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> 1290757258.494523: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> 1290757258.494531: Wireless event: cmd=0x8b1a len=8
> 1290757258.494539: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> 1290757258.494546: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> 1290757258.494552: Wireless event: cmd=0x8b06 len=8
> 1290757258.494559: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> 1290757258.494566: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> 1290757258.494571: Wireless event: cmd=0x8b1a len=12
> 1290757262.734396: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> 1290757262.734422: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> 1290757262.734431: Wireless event: cmd=0x8b19 len=8
> 1290757262.734592: Received 3733 bytes of scan results (14 BSSes)
> 1290757262.734621: BSS: Start scan result update 6
> 1290757262.734669: New scan results available
> 1290757262.734681: RSN: Ignored PMKID candidate without preauth flag
>

What does this mean? Is it relevant?


> 1290757262.734686: Selecting BSS from priority group 0
> 1290757262.734691: Try to find WPA-enabled AP
> 1290757262.734696: 0: 00:24:fe:f9:0c:e6 ssid='FRITZ!Box Fon WLAN 7112'
> wpa_ie_len=24 rsn_ie_len=20 caps=0x11
> 1290757262.734709:    skip - SSID mismatch
> 1290757262.734714: 1: 00:1a:2a:3c:68:b5 ssid='Die3' wpa_ie_len=0
> rsn_ie_len=20 caps=0x11
> 1290757262.734725:    selected based on RSN IE
> 1290757262.734730:    selected WPA AP 00:1a:2a:3c:68:b5 ssid='Die3'
> 1290757262.734746: Already associated with the selected AP
>

It tries to associate, then claims it is already associated. At no point
does iwconfig ever show that it has successfully associated.


> 1290757263.505808: Authentication with 00:1a:2a:3c:68:b5 timed out.
> 1290757263.505823: Added BSSID 00:1a:2a:3c:68:b5 into blacklist


Blacklist? Why?

Sometimes, when it scans, I get this output for the SSID I want to connect
to:


> 1290757258.253370: 1: 00:1a:2a:3c:68:b5 ssid='Die3' wpa_ie_len=0
> rsn_ie_len=20 caps=0x11
> 1290757258.253380:    skip - blacklisted


"skip - blacklisted"? Who is blacklisting whom? What does "wpa_ie_len" mean,
and why is it zero?

I also get this error message:


> ioctl[SIOCSIWFREQ]: Operation not supported


The log output is here (it was too large for the mailing list, though just
21k):
http://pastebin.ca/2003084

Additionally, these files are attached:
test.conf - the configuration file used
iwconfig.txt - output from iwconfig for the relevant interface
scan.txt - iwlist output for the relevant SSID.

I live with roommates, one of whom controls access to the wireless router.
That means that I can't look at the router and so I don't have any idea what
the exact model number is. The fact that I do not have a wired connection
makes troubleshooting this very difficult, as I have to save the log output
to a USB stick and then go to a computer with network access. Were it not
for the fact that my roommates connect without problems, I would have given
up and chalked this up to a crummy router, but since it works for them it
seems embarrassing and silly that it wouldn't work for me.

The key is verified good (I've modified it in the attached test.conf file
for reasons I hope are obvious).

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20101126/788fb8a8/attachment.htm 
-------------- next part --------------
eth1      unassociated  ESSID:off/any  Nickname:"ipw2100"
          Mode:Managed  Channel=0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:5350-2D58-3955-3044-3534-3772   Security mode:open
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:18   Missed beacon:0

-------------- next part --------------
         Cell 14 - Address: 00:1A:2A:3C:68:B5
                    ESSID:"Die3"
                    Protocol:IEEE 802.11g
                    Mode:Master
                    Frequency:2.452 GHz (Channel 9)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality:64  Signal level:0  Noise level:0
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    Extra: Last beacon: 300ms ago
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.conf
Type: application/octet-stream
Size: 76 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20101126/788fb8a8/attachment.obj 


More information about the HostAP mailing list