Upgrade Karmic to wpa_supplicant 0.7.x

Pavel Roskin proski at gnu.org
Tue Mar 23 12:54:55 EDT 2010


On Tue, 2010-03-23 at 00:19 -0600, Curtis Larsen wrote:
> Isn't there an easier way to upgrade from wpa_supplicant 0.6.x on
> ubuntu karmic to 0.7.x?

If Ubuntu packages a newer wpa_supplicant, then there will be an easier
way.  But I don't think they will change the version of wpa_supplicant
in an update for a released distribution.

>   I tried following the README and when I type
> "make" I get the following error:
> 
> for d in ap common crypto drivers eapol_auth eapol_supp eap_common
> eap_peer eap_server l2_packet radius rsn_supp tls utils wps; do [ -d
> $d ] && make -C $d; done
> make: *** [all] Error 1

You missed the real error in the output.

> the README says to create a subdirectory and do "make" there.  But I
> get the following when I do that:
> 
> make: *** No targets specified and no makefile found.  Stop.

There are several README files in the sources.  Only the top-level
README contains the word "subdirectory", but it says nothing about
making a subdirectory.  Search for "directory" brings more results, but
again, I don't see any text about making a directory.

> What am I doing wrong here?

You don't give enough details for others to retrace your steps and
reproduce your problem or to see what you are doing wrong.

-- 
Regards,
Pavel Roskin


More information about the HostAP mailing list