Client can't authenticate

Ervin Hegedüs airween at gmail.com
Sat Mar 6 17:17:40 EST 2010


Hello Jouni,

>> I have a Linux box with hostapd, I have used it since 2 weeks, but
>> today my client can't connect.
>
> So it worked for two weeks, but does not work anymore?
yes, on this week a few day I checked Skype how does it works on
my mobile.. and today morning is not :(

> Did you change something?
no.

> Which kernel version
2.6.31 (exactly 2.6.31-19-generic-pae Ubuntu)

> and which WLAN driver are you using?
do you mean kernel module?
# lsmod | grep 802
mac80211              181108  2 rt2x00usb,rt2x00lib
cfg80211               93052  2 rt2x00lib,mac80211

is it enough info for you?

> Please check whether 'dmesg' shows any errors
> from the driver.
no, there is no any error message.

> Which hostapd version are you using?
# /usr/sbin/hostapd -v
hostapd v0.6.9
User space daemon for IEEE 802.11 AP management,
IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
Copyright (c) 2002-2009, Jouni Malinen <j at w1.fi> and contributors


> Are you using bridging (e.g., wlan0 in br0)?
yes.

Now I came home and let try to use it, my mobile connects to AP
and I can use that.

But.

I closed connection and try to reconnect, and mobile can't see the
SSID. I have restarted hostapd and device can see again...
In log there're just these lines, no more:
Mar  6 23:11:43 thorp dhcpd: DHCPACK on 192.168.72.16 to
00:25:d0:8a:18:7e via br0
Mar  6 23:12:10 thorp dhcpd: DHCPRELEASE of 192.168.72.16 from
00:25:d0:8a:18:7e via br0 (found)
Mar  6 23:12:11 thorp hostapd: wlan0: STA 00:25:d0:8a:18:7e WPA: event
3 notification
Mar  6 23:12:11 thorp hostapd: wlan0: STA 00:25:d0:8a:18:7e IEEE
802.1X: unauthorizing port
Mar  6 23:12:11 thorp hostapd: wlan0: STA 00:25:d0:8a:18:7e IEEE
802.11: deauthenticated
Mar  6 23:12:11 thorp hostapd: wlan0: STA 00:25:d0:8a:18:7e MLME:
MLME-DEAUTHENTICATE.indication(00:25:d0:8a:18:7e, 3)
Mar  6 23:12:11 thorp hostapd: wlan0: STA 00:25:d0:8a:18:7e MLME:
MLME-DELETEKEYS.request(00:25:d0:8a:18:7e)

and restart lines...


Please help me, I'm at lost :(

Is my config right?

Thank you:
a.


More information about the HostAP mailing list