Different county_code config in hostapd and wpa_supplicant

Dennis Borgmann dennis.borgmann at googlemail.com
Fri Dec 17 08:48:13 EST 2010


Jouni,

it's been some time since I came up with the error so I can't remember
anymore, why I was searching this long. I know, I did, but I don't know
anymore, why. Perhaps concentrated on other things while being in
workflow, who knows. Anyway, although the error messages are quite
clear, I'd prefer the two config-items being the same.

Just my opinion, being a "common case user" of hostapd and
wpa_supplicant. Take it as feedback from the outer world.

Kind regards,
Dennis


Jouni Malinen schrieb:
> On Tue, Dec 14, 2010 at 10:44:06AM +0100, Dennis Borgmann wrote:
>   
>> Configuring country code is done in hostapd.conf this way:
>>
>> country=US
>>
>> while in wpa_supplicant.conf it is done this way:
>>
>> country_code=US
>>     
>
> Well, the other way around, but yes, different.
>
>   
>> Is this done by intention or shouldn't it be the same in both the two
>> configurations?
>>     
>
> There is no particular reason for it being different string, but it
> should be kept in mind that the configuration files for hostapd and
> wpa_supplicant are quite different and there are many fields that differ
> from each other.
>
>   
>> Just a thought of mine, since I was searching for this error for maybe
>> 30 minutes, which I could have saved. The way it is now seems to be a
>> little confusing to me.
>>     
>
> How and where were you searching? hostapd should provide quite clear
> pointer on the error:
>
> Line 10: unknown configuration item 'country'
>
> and so does wpa_supplicant:
>
> Line 1: unknown global field 'country_code=US'.
> Line 1: Invalid configuration line 'country_code=US'.
>
>   



More information about the HostAP mailing list