Hostap nl80211 - ath5 : WPA authentication + VLAN assignement

Maxence Dalmais maxence.dalmais at insa-lyon.fr
Mon Oct 26 16:02:21 EDT 2009


On Thu, Oct 22, 2009 at 6:41 PM, Jouni Malinen <j at w1.fi> wrote:

> On Thu, Oct 22, 2009 at 06:23:08PM +0200, Maxence Dalmais wrote:
>
> > I am unable to understand what happens, but just after the binding, my
> whole
> > computer freeze (ie, I have to reboot).
> > I don't know if the problem come from Hostap, the driver, or the kernel.
>
> hostapd should not be able to freeze the computer (hang/crash the kernel
> most likely), i.e., I would expect this to be an issue in the kernel
> (ath5k or mac80211).
>

The problem is the same with compat-wireless version (2.6.32 and the last
git version) , with hostap comming from the last git update.

With the the last stable release, neither crash nor problems in hostapd logs
appears, but vlan is not plainly functionnable. ( Rx and Tx workind
differently ...)

My system in an Ubuntu 9.04 with a 2.6.28 kernel.



>
> > The assignment to the VLAN seems to be OK, but the crash come just after.
> > It looks like a packet arrived just after and make the server crash.
>
> I have not tested this with ath5k, but the last time I tested, dynamic
> VLAN setup was working without problems (I think that test was with
> mac80211_hwsim as the driver).
>

 Is mac80211_hwsim not only to create virtual device for client  ?


>
> > Another probleme that I notice is that the virtual interface created are
> > named "wlan0.X_rename" . Whereas the hostap.vlan file specify "wlan0.X"
> (for
> > example wlan0.5_rename instead of wlan0.5)
> > The i802_set_sta_vlan function use the "wlan0.5" notation.
> > Do you think that could be a part of the problem ? if yes, how to solve
> this
> > ?
>
> I would not expect this to be the cause for the hang. The interface is
> not created as wlan0.X_rename; it is created as wlan0.X. Something else
> in the system is renaming the interface afterwards. I don't know the
> details of your system configuration, so I cannot be sure what is doing
> this, but anyway, I would assume it is udev and its persistent net
> rules. It should be possible to disable that somehow (google udev
> persistent net rules for more info).
>
>

I'm now certain that the problem don't come from here.
I change my hostap.vlan to have vlanX, and that now Ok.


>  > Can somebody give me more information to help me to solve my problem ?
>
> Have you seen any error messages from the kernel? I would suggest
> running the test in text mode (i.e., with kernel messages showing up on
> the console). That may be enough to get the needed information to figure
> out which component is crashing.
>
>
Since my kernel crash, it is pretty hard for me to get a full kernel trace.

I have currently solved my probleme by using the madwifi driver, and having
adapted the patch referenced in http://madwifi-project.org/ticket/446 .


Maxence.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20091026/d3658d50/attachment.htm 


More information about the HostAP mailing list