WPS:external WLAN Manager Registrars

Jouni Malinen j at w1.fi
Fri Oct 23 12:38:42 EDT 2009


On Fri, Oct 23, 2009 at 10:44:22AM +0530, Srinivas Pitla wrote:

> 	4.2.3 Add devices using multiple external Registrars and internal Registrar.

> Microsoft STA configured AP.
> Intel STA(external WLAN Registrar mode) connected to AP.
> Ping from Microsoft STA to Intel STA is succeeded.

> I entered PIN of Atheros STA into Intel STA.
> Then hostapd is receiving the packets,
> but it is not forwarding those packets to Intel STA (observed in sniffer).
> It is giving error as No More registrars available.
> and giving Fail to STA.

Thanks for the details. Based on the debug log, it looks like none of
the external registrar are registered to receive events at this point.
The debug log did not start early enough for me to figure out why this
would have happened (i.e., whether they were registered earlier and
decided to unregister, etc.).

Could you please send me the full debug log from the start of the
hostapd process to this point? It might be better to send this directly
to me (j at w1.fi) since the log is likely to be long enough to go beyond
the mailing list limits.

If you have a chance, it would also be useful to know whether the same
issue shows up with the current development branch (0.7.x; from
hostap.git) snapshot. There have been number of small fixes to WPS since
0.6.9, but I do not remember whether any of these could have fixed this
type of issue.

I'm currently traveling and cannot easily try to reproduce this before
getting back home, so any additional data you can provide could help in
finding out the problems sooner.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list