WPA2 connection issue on embedded ARM system

Michael Hirsch m.hirsch at raumfeld.com
Mon Nov 16 14:35:03 EST 2009


Hello Dirk,

I'm not sure but maybe it helps to know that I have a running system 
here, with an ARM based 2.6.32-rc7 system. We had various trouble with 
the libertas driver but with firmware version 9.70.3p36 most things seem 
to be fine, also with 2.6.31.

Also wpa_supplicant Version 0.6.9 works ok, so the components should 
work in principle.

Best

Michael




Dirk Behme wrote:
> On an embedded ARM system (Gumstix Overo based on TI OMAP3) I have 
> issues to connect to a WPA2 wifi. Kernel is 2.6.31, driver is 
> "libertas: Marvell WLAN 802.11 adapter" with Marvell's 88W8686. 
> Running wpa_supplicant I get:
> 
> -- cut --
> # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -B -d 
> 
> Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 
> 'wext' ctrl_interface 'N/A' bridge 'N/A'
> Configuration file '/etc/wpa_supplicant.conf' -> 
> '/etc/wpa_supplicant.conf'
> Reading configuration file '/etc/wpa_supplicant.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> ctrl_interface_group='0'
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> Priority group 10
>     id=0 ssid='WLAN-001F3F12FA7D'
> Initializing interface (2) 'wlan0'
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=15 enc_capa=0xf
>    capabilities: key_mgmt 0xf enc 0xf flags 0x0
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:19:88:20:fa:20
> wpa_driver_wext_set_wpa
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_countermeasures
> wpa_driver_wext_set_drop_unencrypted
> RSN: flushing PMKID list in the driver
> Setting scan request: 0 sec 100000 usec
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> ctrl_interface_group=0
> Added interface wlan0
> Daemonize..
> -- cut --
> 
> Does anybody see any obvious issues here? Running udhcpc on this fails 
> then. It seems to me that no 'connection' is established?
> 
> See below for more details.
> 
> Many thanks and best regards
> 
> Dirk
> 
> Log details:
> 
> ....
> lib80211: common routines for IEEE802.11 drivers
> libertas_sdio: Libertas SDIO driver
> libertas_sdio: Copyright Pierre Ossman
> libertas_sdio mmc1:0001:1: firmware: requesting sd8686_helper.bin
> libertas_sdio mmc1:0001:1: firmware: requesting sd8686.bin
> libertas: 00:19:88:20:fa:20, fw 9.70.3p24, cap 0x00000303
> libertas: eth1: Marvell WLAN 802.11 adapter
> udev: renamed network interface eth1 to wlan0
> ....
> 
> # iwlist wlan0 scan
> wlan0     Scan completed :
>            Cell 01 - Address: 00:1F:3F:12:FA:7D
>                      ESSID:"WLAN-001F3F12FA7D"
>                      Mode:Managed
>                      Frequency:2.462 GHz (Channel 11)
>                      Quality=97/100  Signal level=-51 dBm  Noise 
> level=-96 dBm
>                      Encryption key:on
>                      Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
>                                9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
>                                48 Mb/s; 54 Mb/s
>                      IE: WPA Version 1
>                          Group Cipher : TKIP
>                          Pairwise Ciphers (1) : TKIP
>                          Authentication Suites (1) : PSK
>                      IE: IEEE 802.11i/WPA2 Version 1
>                          Group Cipher : TKIP
>                          Pairwise Ciphers (1) : CCMP
>                          Authentication Suites (1) : PSK
> 
> # cat /etc/wpa_supplicant.conf
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=0
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> 
> network={
>        ssid="WLAN-001F3F12FA7D"
>        proto=WPA2
>        key_mgmt=WPA-PSK
>        pairwise=CCMP
>        group=TKIP
>        scan_ssid=0
>        psk=47.........................................8c23
>        priority=10
> }
> 
> # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -B -d 
> 
> Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 
> 'wext' ctrl_interface 'N/A' bridge 'N/A'
> Configuration file '/etc/wpa_supplicant.conf' -> 
> '/etc/wpa_supplicant.conf'
> Reading configuration file '/etc/wpa_supplicant.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> ctrl_interface_group='0'
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> Priority group 10
>     id=0 ssid='WLAN-001F3F12FA7D'
> Initializing interface (2) 'wlan0'
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=15 enc_capa=0xf
>    capabilities: key_mgmt 0xf enc 0xf flags 0x0
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:19:88:20:fa:20
> wpa_driver_wext_set_wpa
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_countermeasures
> wpa_driver_wext_set_drop_unencrypted
> RSN: flushing PMKID list in the driver
> Setting scan request: 0 sec 100000 usec
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> ctrl_interface_group=0
> Added interface wlan0
> Daemonize..
> 
> # iwconfig wlan0
> wlan0     IEEE 802.11b/g  ESSID:""
>            Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated
>            Bit Rate:0 kb/s   Tx-Power=13 dBm
>            Retry short limit:8   RTS thr=2347 B   Fragment thr=2346 B
>            Encryption key:<too big>   Security mode:open
>            Power Management:off
>            Link Quality:0  Signal level:0  Noise level:0
>            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>            Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> 
> 
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
> 



More information about the HostAP mailing list