Help getting Senao SL-2511 wireless cards working using hostap on Ubuntu 8.10. (Part 1)

Groves, Randy randy.groves at boeing.com
Tue May 12 12:15:29 EDT 2009


(Yes I know I'm being a pest.  Damn MS Outlook is expanding the size of this message.)

 

Granted - these cards are old.  We are trying to reproduce some results from some CMU research circa 2003: http://www.cs.cmu.edu/~glennj/JuddNSDIEmulator.pdf.

 

We need to be able to adjust rate, channel, and if possible, transmit power.

 

We've got two IBM Thinkpads - we know that the cards are at least functional.  Rebooting into the Windows image that is on these same machines reveals that, once the appropriate drivers were loaded, that we can at least get them talking to each other in managed mode.

 

Here's the setup:

 

Ubuntu server 8.10 with all current upgrades and updates

Kernel is 2.6.27-7

 

The Orinoco drivers are blacklisted in /etc/modprobe.d/hostap-utils.

We are NOT starting the hostapd daemon.

 

For sensor1 the following applies:

 

'lshw -C network' reveals:

 

  *-network

       description: HFA384x/IEEE

       product: Version 01.02

       vendor: INTERSIL

       physical id: 0

       slot: Socket 0

       resources: irq:4

  *-network:0

       description: Wireless interface

       physical id: 1

       logical name: wlan0

       serial: 00:02:6f:47:d6:27

       capabilities: ethernet physical wireless

       configuration: broadcast=yes driver=hostap firmware=1.8.0 ip=10.10.1.10 multicast=yes wireless=IEEE 802.11b

 

'ifconfig wlan0' in this machine:

 

wlan0     Link encap:Ethernet  HWaddr 00:02:6f:47:d6:27

          inet addr:10.10.1.10  Bcast:10.10.1.255  Mask:255.255.255.0

          inet6 addr: fe80::202:6fff:fe47:d627/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:2176 overruns:0 frame:0

          TX packets:84 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:12950 (12.9 KB)

          Interrupt:4 Base address:0x8100

 

'iwconfig wlan0' (in managed mode):

 

wlan0     IEEE 802.11b  ESSID:"visitornet▒"  Nickname:""

          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:14:1C:C8:9F:B2

          Bit Rate:11 Mb/s   Sensitivity=1/3

          Retry short limit:8   RTS thr:off   Fragment thr:off

          Encryption key:off

          Power Management:off

          Link Quality=47/70  Signal level=-43 dBm  Noise level=-90 dBm

          Rx invalid nwid:0  Rx invalid crypt:7315  Rx invalid frag:0

          Tx excessive retries:1637  Invalid misc:589279   Missed beacon:0

 

(Rest in part 2)

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090512/5228ac3c/attachment.htm 


More information about the HostAP mailing list