wpa_supplicant fails for WPS mode

Jagadish Murugan jugs.8724 at gmail.com
Mon Mar 23 02:47:26 EDT 2009


Hi,

Following is the WLAN card & driver details I am using:

WLAN Card   - "Dell Wireless 1395 WLAN Mini-Card"
Driver Version - "4.170.25.2"

I am gonna try the following version: 4.170.77.3 version of the driver. In
the meanwhile it would be great if you could confirm if this version
actually supports WPS.

Thanks & Regards,
Jagadish.

On Thu, Mar 19, 2009 at 11:43 PM, Jouni Malinen <j at w1.fi> wrote:

> On Thu, Mar 19, 2009 at 07:07:46PM +0530, Jagadish Murugan wrote:
>
> > I am currently porting WPS for an embedded platform and am using
> > wpa_supplicant to learn the WPS protocol. I am using the windows version
> of
> > WPS and VC++ for the development environment. I have been able to use
> > wpa_supplicant (version 0.6.8) to connect using WPA, but it fails in WPS
> > mode (both PBC & PIN method).
> > I see the following logs on "Event History" window:
> >
> > CTRL-EVENT-SCAN-RESULTS
> > WPS-AP-AVAILABLE-SCAN
> > Trying to associate with (AP's BSSID)
> > Authentication with (AP's BSSID) timed out
>
> Which WLAN card and driver are you using? The driver may not support the
> special association parameters (no security with WPA-Personal AP) needed
> for WPS.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090323/979d2912/attachment.htm 


More information about the HostAP mailing list