libnl.so.2.0: cannot open shared object file: No such file or directory upon start

Pavel Roskin proski at gnu.org
Fri Mar 13 13:49:05 EDT 2009


On Fri, 2009-03-13 at 13:38 -0400, Cengiz Günay wrote:
> For people who try to use the LIBNL >= 2.0, it would be very nice to
> apply this patch in to the hostapd/defconfig file:
...
> +# If you have libnl version >= 2.0 then also enable the following:
> +#CONFIG_LIBNL20=y

It would be much better to do it automatically, like in the iw makefile:

NL1FOUND := $(shell pkg-config --atleast-version=1 libnl-1 && echo Y)
NL2FOUND := $(shell pkg-config --atleast-version=2 libnl-2.0 && echo Y)

ifeq ($(NL1FOUND),Y)
NLLIBNAME = libnl-1
endif

ifeq ($(NL2FOUND),Y)
CFLAGS += -DCONFIG_LIBNL20
LIBS += -lnl-genl
NLLIBNAME = libnl-2.0
endif

Users should not be expected to verify versions of the libraries they
have on their systems.

-- 
Regards,
Pavel Roskin


More information about the HostAP mailing list