[WEP] can't connect to my network

Atton Jonathan jonathan.atton at gmail.com
Mon Mar 9 15:14:47 EDT 2009


I m sorry, I found the solution while I was writting this message.
I have un-installed network-manager, reboot the computer and now it works. I
found no process named network* ou nm* so I don't understand but I suppose
it was somewhere :)

2009/3/9 Atton Jonathan <jonathan.atton at gmail.com>

> Hello ,
>
> I try to connect my laptop to my router DLink. I use the driver wext with
> the wireless card Intel 3945ABG.
>
> My wpa_supplicant.conf file is:
> ctrl_interface=/var/run/wpa_supplicant
> ap_scan=1
> network={
>   ssid="Watchwolf23"
>   key_mgmt=NONE
>   wep_key0=1111111111
>   wep_tx_keyidx=0
>   priority=5
>   auth_alg=SHARED
> }
>
> I run wpa_supplicant with (as root)
> wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
> -P/var/run/wpa_supplicant -B
>
> then I run wpa_cli and I run these commandes:
> RECONFIGURE (no fail)
>
> then STATUS return wpa_state=SCANNING
> and I have :
> trying to associate with 02:....... (SSID='Watchwolf23' freq=2412MHz)
> Associated with 02:.....
> CTRL-EVENT-CONNECTED - Connection to 02:.... completed (reauth) [id=0
> id_str=]
> CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
>
> it seems wpa_supplicant connect my interface to the network but then
> disconnect ...
> dhclient fails :/
>
> I tried with some alternate configuration:
> no auth_alg
> ap_scan=0 (seems to be conencted but dhclien fails)
> ap_scan=2 (trying to associate, then timeout)
> wep_key0="11111111" (trying to assocate, then timeout)
>
> my configurationo on the router is simple: WEP, key: 1111111111, open and
> shared key.
>
> --
> Regards.
>



-- 
Regards.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090309/68532edc/attachment.htm 


More information about the HostAP mailing list