hostapd not working correctly?

Andrzej Kosmala kosmal at cyberia.pl
Tue Jun 30 14:53:28 EDT 2009


I'm using ralink rt61pci and hostapd on 2.6.30 kernel.
After building br0 for wlan0 and eth0. /etc/network/interfaces abount br0:
auto br0
iface br0 inet static
        address 192.168.1.50
        netmask 255.255.255.0
        network 192.168.2.0
        broadcast 192.168.1.255
        pre-up /etc/init.d/hostapd start
        bridge_ports eth0 wlan0

Then I did:
iptables -t nat -A POSTROUTING -o eth1 -s 192.168.1.52 -j SNAT 
--to-source 83.15.249.186
        iptables -A FORWARD -i br0 -o eth1 -s 192.168.1.52 -j ACCEPT 
#notebook
        iptables -A FORWARD -m state --state ESTABLISHED,RELATED -d 
192.168.2.52 -j ACCEPT
As for 20 komputers on eth0.

My hostapd conf:
interface=wlan0
bdriver=nl80211
bridge=br0
hw_mode=g
channel=11
ssid=ralink
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=1

Windows notebook can connect but hasn't internet.
For taying ssh I do:
ip addr add 192.168.1.50/24 dev wlan0
and ifconfig wlan0 shows:wlan0     Link encap:Ethernet  HWaddr 
00:30:cd:0d:37:57 
          inet addr:192.168.1.50  Bcast:0.0.0.0  Mask:255.255.255.0
          inet6 addr: fe80::230:cdff:fe0d:3757/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:188 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2183 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21814 (21.3 KiB)  TX bytes:312174 (304.8 KiB)

I can't connect throught ssh but ping 192.168.1.50 answers.

In /var/log/kern.log I found:
 Jun 30 19:10:26 router kernel: [78701.909788] wlan0: STA 
00:21:63:90:51:29 aid 1 exits power save mode
---------- many the same lines -----------------
Jun 30 19:10:28 router kernel: [78704.030155] wlan0: STA 
00:21:63:90:51:29 aid 1 enters power save mode
Jun 30 19:10:52 router kernel: [78727.755994] wlan0: BC TX buffer full - 
dropping the oldest frame
------------- many the same lines----------------
Jun 30 19:10:59 router kernel: [78734.968583] wlan0: BC TX buffer full - 
dropping the oldest frame
Jun 30 19:11:05 router kernel: [78740.469390] __ratelimit: 9 callbacks 
suppressed
Jun 30 19:11:05 router kernel: [78740.469467] wlan0: BC TX buffer full - 
dropping the oldest frame
------------many the same lines --------------
Jun 30 19:15:20 router kernel: [78995.689609] wlan0: BC TX buffer full - 
dropping the oldest frame
Jun 30 19:16:02 router kernel: [79037.668109] STA 00:21:63:90:51:29 aid 
1: PS buffer (entries before 0)
Jun 30 19:16:03 router kernel: [79038.672079] STA 00:21:63:90:51:29 aid 
1: PS buffer (entries before 1)
Jun 30 19:16:04 router kernel: [79039.675831] STA 00:21:63:90:51:29 aid 
1: PS buffer (entries before 2)
Jun 30 19:16:04 router kernel: [79039.676297] phy0: Removed STA 
00:21:63:90:51:29
Jun 30 19:16:04 router kernel: [79039.676372] phy0: Destroyed STA 
00:21:63:90:51:29
What is bad with my access point.
Regarda Andrzej



More information about the HostAP mailing list