hostapd and dnsmasq

Jhonny Boy jhonnyboy at ymail.com
Thu Jun 11 16:31:13 EDT 2009


I fix the first error
and there is no error on line 180 if it is : auth_algs=1

I can now see my AP and connect me to it.
Is it normal for an open hotspot?

I'll try to configure iptables to share internet and have a good protection 

--- En date de : Jeu 11.6.09, GNUtoo <GNUtoo at no-log.org> a écrit :

De: GNUtoo <GNUtoo at no-log.org>
Objet: Re: hostapd and dnsmasq
À: "Jhonny Boy" <jhonnyboy at ymail.com>
Cc: hostap at lists.shmoo.com
Date: Jeudi 11 Juin 2009, 19h44

On Thu, 2009-06-11 at 19:21 +0000, Jhonny Boy wrote:
> Hello
> I am using gentoo and I would like to set up on open acces point to share my internet connection. I would like to use dnsmasq for this task.
> 
> I didn't anydocumentation on this except this page that doesn't work any more : http://us.gentoo-wiki.com/HOWTO_libnl_AP
> 
> I am currently having this message :
>  * Caching service dependencies ...   [ ok ]
>  * Starting hostapd ...
> Configuration file: /etc/hostapd/hostapd.conf
> Line 17: unknown configuration item ' driver'
> Line 180: no authentication algorithms allowed
> 2 errors found in configuration file '/etc/hostapd/hostapd.conf' 
> 
> hostapd.conf contain,
> line 17 :  driver=nl80211
> line 180 : auth_algs=0
hi,
it seems that you are using gentoo...
if I remember well,when I made this howto the hostap ebuild checked for
some headers in the kernel before enabling nl80211 driver...but now it's
enabled by default
which version of hostapd did you emerge?
(by the way I'm not an hostap expert...I just made it work on my router
and wrote this howto)
Denis.




      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090611/799a2ca1/attachment.htm 


More information about the HostAP mailing list