Private key message

Michael Kurecka wpi.hostapd at gmail.com
Thu Jul 30 09:37:53 EDT 2009


I'm setup for EAP-TLS with following .conf file:

network={
        ssid="WIM-TLS"
        proto=RSN
        key_mgmt=WPA-EAP
        group=CCMP
        eap=TLS
        identity="admin"
        password="wpi01"
        ca_cert="/etc/cert/TrustedCA.pem"
        private_key="/etc/cert/projects.pfx"
        private_key_passwd=""
        pairwise=CCMP
}

and I'm getting the following messages:

OpenSSL: tls_connection_private_key - SSL_use_PrivateKey_File (DER)
failed error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
OpenSSL: pending error: error:0D06C03A:asn1 encoding
routines:ASN1_D2I_EX_PRIMITIVE:nested asn1 error
OpenSSL: pending error: error:0D08303A:asn1 encoding
routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error
OpenSSL: pending error: error:0D09A00D:asn1 encoding
routines:d2i_PrivateKey:ASN1 lib
OpenSSL: pending error: error:140CB00D:SSL
routines:SSL_use_PrivateKey_file:ASN1 lib
OpenSSL: tls_connection_private_key - SSL_use_PrivateKey_File (PEM)
failed error:0906D06C:PEM routines:PEM_read_bio:no start line
OpenSSL: pending error: error:140CB009:SSL
routines:SSL_use_PrivateKey_file:PEM lib

they are only MSG_DEBUG messages and it seems to be working but is this
normal or a problem with my private key file? If a problem, what is the
issue? No problem was seen when I applied the projects.pfx file on a XP
machine.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090730/9d382e4a/attachment.htm 


More information about the HostAP mailing list