wpa_supplicant doesn't reconnect to AP (after turning off/on AP)

Pongsak Tawankanjanachot egapongsak at gmail.com
Tue Feb 24 22:08:23 EST 2009


Dear Sir,
   I'm using wpa_supplicant (with Ralink chipset) to connect with Access
point (Ralink chipset).
   My security setting is WPA2 by using freeradius as a Radius server.

     wpa_supplicant.conf is
ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
network={
        ssid="TEST_AP"
        key_mgmt=WPA-EAP IEEE8021X
        pairwise=TKIP CCMP
        eap=PEAP
        phase1="peaplabel=0"
        phase2="auth=MSCHAPV2"
        identity="test"
        password="test"
}

   Firstly, the supplicant successfully connects to AP (access point)
   Then, I turn off/on the AP, wpa_supplicant tries to reauthenticate and
show debug message like: (just some part of whole messages)

Custom wireless event: receive ASSOCIATED_EVENT !!!
wpa_driver_ralink_get_bssid
State: DISCONNECTED -> ASSOCIATED
wpa_driver_ralink_get_bssid
Associated with 00:1d:7d:09:51:74
WPA: Association event - clear replay counter
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: maintaining EAP method data for fast reauthentication
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
attr3:  - hexdump(len=4): 20 52 65 73
EAPOL: startWhen --> 0
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
RSN: PMKSA caching - do not send EAPOL-Start
EAPOL: authWhile --> 0

Authentication with 00:1d:7d:09:51:74 timed out.
wpa_driver_ralink_get_bssid
wpa_driver_ralink_get_associnfo
wpa_driver_ralink_get_associnfo: association success
wpa_driver_ralink_poll_timeout: Connected!!
wpa_driver_ralink_get_bssid
State: SCANNING -> ASSOCIATED
wpa_driver_ralink_get_bssid
Associated with 00:1d:7d:09:51:74
WPA: Association event - clear replay counter
EAPOL: External notification - portEnabled=0
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portValid=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: maintaining EAP method data for fast reauthentication
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Cancelling scan request
EAPOL: startWhen --> 0
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
RSN: PMKSA caching - do not send EAPOL-Start
Authentication with 00:1d:7d:09:51:74 timed out.

    wpa_supplicant cannot reconnect to AP because of PMKSA caching??
    I've tried the supplicant with LinkSys AP, (turn off/on LinkSysAP),
wpa_supplicant works fine. It reconnects to AP.
    Or some issue at the Access point (Ralink chipset)?

    Please share your idea.

Regards,
Pongsak
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090225/8d4a5848/attachment.htm 


More information about the HostAP mailing list