building wpasupplicant 0.6.7

Janne Pylvänäinen jpylvanainen at hotmail.com
Tue Feb 24 17:30:34 EST 2009


Hey guys, I'm trying to build wpa_supplicant for wps. 
I've succesfully patched openssl0.9.8g

while building there comes this:

make
cc  -o wpa_supplicant config.o ../src/utils/common.o ../src/utils/wpa_debug.o ../src/utils/wpabuf.o ../src/crypto/md5.o ../src/crypto/rc4.o ../src/crypto/md4.o ../src/crypto/sha1.o ../src/crypto/des.o ../src/utils/os_unix.o ../src/utils/eloop.o config_file.o ../src/eap_peer/eap_otp.o ../src/eap_peer/eap_psk.o ../src/eap_common/eap_psk_common.o ../src/eap_peer/eap_aka.o ../src/eap_common/eap_sim_common.o wps_supplicant.o ../src/utils/uuid.o ../src/eap_peer/eap_wsc.o ../src/eap_common/eap_wsc_common.o ../src/wps/wps.o ../src/wps/wps_common.o ../src/wps/wps_attr_parse.o ../src/wps/wps_attr_build.o ../src/wps/wps_attr_process.o ../src/wps/wps_dev_attr.o ../src/wps/wps_enrollee.o ../src/wps/wps_registrar.o ../src/eapol_supp/eapol_supp_sm.o ../src/eap_peer/eap.o ../src/eap_common/eap_common.o ../src/eap_peer/eap_methods.o ../src/utils/pcsc_funcs.o ../src/crypto/tls_none.o ../src/crypto/sha256.o ../src/rsn_supp/wpa.o ../src/rsn_supp/preauth.o ../src/rsn_supp/pmksa_cache.o ../src/rsn_supp/peerkey.o ../src/rsn_supp/wpa_ie.o ../src/common/wpa_common.o ../src/crypto/aes_wrap.o ../src/crypto/aes.o ../src/crypto/dh_groups.o ../src/utils/base64.o ../src/drivers/scan_helpers.o wpa_supplicant.o events.o blacklist.o wpas_glue.o scan.o main.o ../src/drivers/driver_wext.o ../src/drivers/drivers.o ../src/l2_packet/l2_packet_linux.o -lpcsclite -lpthread 
../src/wps/wps_common.o: In function `wps_derive_keys':
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/wps/wps_common.c:100: undefined reference to `sha256_vector'
../src/wps/wps_common.o: In function `wps_derive_mgmt_keys':
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/wps/wps_common.c:158: undefined reference to `sha256_vector'
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/wps/wps_common.c:165: undefined reference to `sha256_vector'
../src/crypto/sha256.o: In function `hmac_sha256_vector':
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/crypto/sha256.c:77: undefined reference to `sha256_vector'
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/crypto/sha256.c:90: undefined reference to `sha256_vector'
../src/crypto/sha256.o:/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/crypto/sha256.c:49: more undefined references to `sha256_vector' follow
../src/crypto/dh_groups.o: In function `dh_derive_shared':
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/crypto/dh_groups.c:609: undefined reference to `crypto_mod_exp'
../src/crypto/dh_groups.o: In function `dh_init':
/home/jaba/src/wpa_supplicant-0.6.8/wpa_supplicant/../src/crypto/dh_groups.c:573: undefined reference to `crypto_mod_exp'
collect2: ld returned 1 exit status
make: *** [wpa_supplicant] Error 1

Can you tell me where I did wrong? 

.config file:

CONFIG_TLS=internal 
CONFIG_INTERNAL_LIBTOMMATH=y
CONFIG_EAP_AKA=y
CONFIG_EAP_PSK=y
CONFIG_PCSC=y
CONFIG_EAP_OTP=y
CONFIG_EAP_PSK=y
CONFIG_DRIVER_WEXT=y
CONFIG_EAP=y
CONFIG_WPS=y

first two lines doesn't affect the result

My operating system is Ubuntu Intrepid. 

Thanks in advance


_________________________________________________________________
Liity nyt uuteen Windows Live Messenger perheeseen
http://get.live.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090224/50524555/attachment-0001.htm 


More information about the HostAP mailing list