hostapd-0.6.8 + madwifi + bridge + WPA-PSK

Michael Voorhaen michael.voorhaen at ua.ac.be
Mon Feb 23 04:18:19 EST 2009


It seems that my problem doesn't exist when I start hostap as a  
service on my voyage installation. The problem does persist when I  
start it from the command-line with exactly the same configuration  
file. Maybe additional arguments are added by the service script  
somehow. The actual problem still eludes me though.

Regards,
Michael

-------------------------
IBBT - PATS research group
Dept. of Mathematics and Computer Sciences
University of Antwerp
Campus Middelheim, G3.30
Middelheimlaan 1
B-2020 Antwerpen, Belgium
Phone: +32 (0)3 265.32.91
Fax: +32 (0)3 265.37.77
Web: www.pats.ua.ac.be/michael.voorhaen







On 23 Feb 2009, at 07:10, Michael Voorhaen wrote:

> I was thinking it would be something like this. I'm guessing this  
> commit is already in 0.6.8, and since its a change in the nl80211  
> driver it should have nothing to do with my madwifi problem. It is  
> strange that I have exactly the same behaviour with the madwifi  
> driver. Perhaps I should dive into the code.
>
> I notice that in driver_madwifi.c there is a goto bad statement  
> after the "Configure bridge %s for EAPOL traffic." debug statement,  
> which could mean that the interfacing with madwifi could go wrong  
> and not be logged.
>
> Regards,
> Michael
>
> -------------------------
> IBBT - PATS research group
> Dept. of Mathematics and Computer Sciences
> University of Antwerp
> Campus Middelheim, G3.30
> Middelheimlaan 1
> B-2020 Antwerpen, Belgium
> Phone: +32 (0)3 265.32.91
> Fax: +32 (0)3 265.37.77
> Web: www.pats.ua.ac.be/michael.voorhaen
>
>
>
>
>
>
>
> On 23 Feb 2009, at 01:44, John Klehm wrote:
>
>> On Sun, Feb 22, 2009 at 2:59 PM, Michael Voorhaen
>> <michael.voorhaen at ua.ac.be> wrote:
>> > I have just been browsing the archives and found this post that
>> > describes exactly the same problem:
>> >
>> > http://lists.shmoo.com/pipermail/hostap/2008-July/018021.html
>> >
>> > Then there is an answer in the next mail in the thread and i quote:
>> > "You need eaaab2bd98b0b08f1ff77303a0f142af029884a6." What does this
>> > mean is it a revision from the cvs/svn you are using? I get the
>> > impression that someone fixed this, but I don't see how :D.
>> >
>>
>> http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=commit;h=eaaab2bd98b0b08f1ff77303a0f142af029884a6
>>
>> That gibberish is the cryptographic fingerprint of the code diff that
>> git uses to track the change.  The link I posted is the web interface
>> to hostapd's git  with the commit in question.
>>
>> Hope this helps,
>> --John Klehm
>>
>
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090223/4113b2a8/attachment.htm 


More information about the HostAP mailing list