Compiling hostap against openssl 0.9.8k

Jouni Malinen j at w1.fi
Mon Aug 31 05:55:07 EDT 2009


On Sun, Aug 30, 2009 at 10:48:06PM -0700, Philip A. Prindeville wrote:
> I'm building hostap from git (2009-08-23).  I've attached my config
> file.  I'm seeing:

> ../src/crypto/tls_openssl.o: In function `tls_connection_set_session_ticket_cb':
> /home/philipp/asterisk/build_i586/hostapd-2009-08-23/hostapd/../src/crypto/tls_openssl.c:2705: undefined reference to `SSL_set_session_secret_cb'

> Are there patches to compile against openssl-0.9.8k?  Or do I just need additional CFLAGS?

> CONFIG_EAP_FAST=y

EAP-FAST support with OpenSSL 0.9.8 requires a patch
(patches/openssl-0.9.8i-tls-extensions.patch in case of 0.9.8k).

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list