WPA_Supplicant failing for LEAP

linux newbie linux.newbie79 at gmail.com
Wed Apr 29 20:19:30 EDT 2009


>
> Hi,
>
> I downloaded latest airo driver which has WPA support from below mentioned
> website
> http://svn.gna.org/viewcvs/airo-wpa/?sortdir=down
>
> Following is my wpa_configuration settings
>
> ctrl_interface=/var/run/wpa_supplicant
> network={
>         ssid="RTSDEV8"
>         proto=WPA
>         key_mgmt=WPA-PSK
>         pairwise=TKIP
>         group=TKIP
>         auth_alg=OPEN
> psk=b4a199f9efdf4d94e4c86562f6d54e1db61fb7faa5b0d32e0104690bb63919db
> }
>
> I am getting following error. Can you please suggest what might went wrong?
>
> # ./wpa_supplicant -Dwext -i eth1 -c my_conf.conf -dd
> Initializing interface 'eth1' conf 'my_conf.conf' driver 'wext'
> ctrl_interface 'N/A' bridge 'N/A'
> Configuration file 'my_conf.conf' -> '/mnt/wpa_supplicant/my_conf.conf'
> Reading configuration file '/mnt/wpa_supplicant/my_conf.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> Line: 6 - start of a new network block
> ssid - hexdump_ascii(len=7):
>      52 54 53 44 45 56 38                              RTSDEV8
> proto: 0x1
> key_mgmt: 0x2
> pairwise: 0x8
> group: 0x8
> auth_alg: 0x1
> PSK - hexdump(len=32): [REMOVED]
> Priority group 0
>    id=0 ssid='RTSDEV8'
> Initializing interface (2) 'eth1'
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=19 enc_capa=0x0
>   capabilities: key_mgmt 0x0 enc 0x3 flags 0x0
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:0d:28:7f:4b:c0
> wpa_driver_wext_set_wpa
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_countermeasures
> wpa_driver_wext_set_drop_unencrypted
> RSN: flushing PMKID list in the driver
> Setting scan request: 0 sec 100000 usec
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> Added interface eth1
> RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
> Wireless event: cmd=0x8b06 len=8
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
> State: DISCONNECTED -> SCANNING
> Starting AP scan (broadcast SSID)
> Trying to get current scan results first without requesting a new scan to
> speed up initial association
> Received 126 bytes of scan results (1 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - no WPA/RSN IE
> Try to find non-WPA AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - non-WPA network not allowed
> No suitable AP found.
> Setting scan request: 0 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 5 seconds
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b15 len=20
> Wireless event: new AP: 00:00:00:00:00:00
> Added BSSID 00:00:00:00:00:00 into blacklist
> CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> State: SCANNING -> DISCONNECTED
> wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> WEXT: Operstate: linkmode=-1, operstate=5
> EAPOL: External notification - portEnabled=0
> EAPOL: External notification - portValid=0
> EAPOL: disable timer tick
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b19 len=8
> Received 0 bytes of scan results (0 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> Try to find non-WPA AP
> No APs found - clear blacklist and try again
> Removed BSSID 00:00:00:00:00:00 from blacklist (clear)
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> Try to find non-WPA AP
> No suitable AP found.
> Setting scan request: 5 sec 0 usec
> State: DISCONNECTED -> SCANNING
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 30 seconds
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b19 len=8
> Received 126 bytes of scan results (1 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - no WPA/RSN IE
> Try to find non-WPA AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - non-WPA network not allowed
> No suitable AP found.
> Setting scan request: 5 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 30 seconds
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b19 len=8
> Received 126 bytes of scan results (1 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - no WPA/RSN IE
> Try to find non-WPA AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - non-WPA network not allowed
> No suitable AP found.
> Setting scan request: 5 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 30 seconds
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b19 len=8
> Received 126 bytes of scan results (1 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - no WPA/RSN IE
> Try to find non-WPA AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - non-WPA network not allowed
> No suitable AP found.
> Setting scan request: 5 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 30 seconds
> RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
> Wireless event: cmd=0x8b19 len=8
> Received 126 bytes of scan results (1 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - no WPA/RSN IE
> Try to find non-WPA AP
> 0: 00:07:85:b3:fe:a1 ssid='RTSDEV8' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
>    skip - non-WPA network not allowed
> No suitable AP found.
> Setting scan request: 5 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 30 seconds
> CTRL-EVENT-TERMINATING - signal 2 received
> Removing interface eth1
> State: SCANNING -> DISCONNECTED
> wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
> WEXT: Operstate: linkmode=-1, operstate=5
> No keys have been configured - skip key clearing
> EAPOL: External notification - portEnabled=0
> EAPOL: External notification - portValid=0
> wpa_driver_wext_set_wpa
> wpa_driver_wext_set_drop_unencrypted
> wpa_driver_wext_set_countermeasures
> No keys have been configured - skip key clearing
> Cancelling scan request
> Cancelling authentication timeout
> WEXT: Operstate: linkmode=0, operstate=6
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090430/99352b39/attachment-0001.htm 


More information about the HostAP mailing list