WPA_Supplicant failing for LEAP

Jouni Malinen j at w1.fi
Sun Apr 26 03:59:38 EDT 2009


On Mon, Apr 20, 2009 at 10:35:04AM +1000, linux newbie wrote:

> Our AP is connected to Radius Server and LEAP is enabled. when I tried using
> wpa_supplicant in my sytem(cisco wireless card and wext driver) it throws
> following error. Please help to resolve this issue.
> *wpa_driver_wext_associate
> ioctl[SIOCSIWGENIE]: Operation not supported*

You can ignore that message.

> network={
>         ssid="RTSDEV4"
>         key_mgmt=IEEE8021X
>         eap=LEAP
>         identity="nandaks"
>         password="*******"
>         priority=5
> }

But it looks like your driver does not support Network EAP
authentication algorithm. If the AP allows LEAP to be used without it,
you could try adding auth_alg=OPEN into the network block.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list