wpa_supplicant : Association request to the driver failed

lijinlei1 lijinlei1 at 163.com
Tue Apr 7 02:41:19 EDT 2009


Hi Dan,

Thanks for your reply.
I am using the 2.6.24 stock kernel from kernel.org, and i.MX31L (3-stack) platform. I applied the freescale patch to get the SDIO working.
I tried 2 options: 2.6.24 libertas (from stock kernel) + v8.73 firmware (from Marvell), not work.
                   2.6.27 libertas (from stock kernel) + v9.70 firmware (from Marvell), still no luck.

The logs from wpa_supplicant 0.6.9 are the same for the 2 options above.
I traced the call sequences, I found in wpa_driver_wext_associate():

line 2096:
 if (wpa_driver_wext_set_auth_param(drv,
        IW_AUTH_PRIVACY_INVOKED, value) < 0)
  ret = -1;
and line 2111:
 if (wpa_driver_wext_set_auth_param(drv,
        IW_AUTH_RX_UNENCRYPTED_EAPOL,
        allow_unencrypted_eapol) < 0)

Those 2 calls failed. The libertas driver can't handle those 2 ioctls: IW_AUTH_PRIVACY_INVOKED and IW_AUTH_RX_UNENCRYPTED_EAPOL, with value 10 and 8 respectively.
Will this be the cause of the association failure?
Thanks.

----- Original Message ----- 
From: "Dan Williams" <dcbw at redhat.com>
To: "lijinlei1" <lijinlei1 at 163.com>
Cc: <hostap at lists.shmoo.com>
Sent: Tuesday, April 07, 2009 4:16 AM
Subject: Re: wpa_supplicant : Association request to the driver failed


> On Fri, 2009-04-03 at 14:11 +0800, lijinlei1 wrote:
>> Hi guys,
>>  
>> I don't know if this is the right place to ask such kind of questions,
>> but I really run out of ideas.
>>  
>> Chip: Marvell sd8686 (SDIO based)
>> Kernel: Linux 2.6.24
>> Driver: libertas with wireless extension (V22)
>>  
>> Everything works fine, I also got a scan result using "iwlist eth0
>> scan" command. But I failed to connect to my AP (WPA-PSK TKIP) with
>> wpa_supplicant.
>>  
>> Configuration file:
>> $ cat /etc/wpa.conf
>> # WPA-PSK/TKIP
>>  
>> ctrl_interface=/var/run/wpa_supplicant
>>  
>> network={
>>     ssid="tiger"
>>     key_mgmt=WPA-PSK
>>     proto=WPA
>>     pairwise=TKIP
>>     group=TKIP
>>     psk="OnyxWpa2009"
>> }
> 
> Are you using the stock 2.6.24 libertas_sdio driver?  What SDIO host
> controller are you using, and what platform?  What firmware are you
> using, 8.x or 9.x?
> 
> wpa_supplicant prints this out if *any* of the calls during the
> association procedure fail; some of those are expected to fail because
> drivers don't necessarily support all the options that the supplicant
> requests.  Most of the time that should be fine.  What you can try to do
> is put some additional debugging information into
> wpa_driver_wext_associate() and see which of the calls in that function
> returns an error and sets ret to -1.  That will give more info.
> 
> Next, you can add WEXT debugging to the libertas.ko module when you
> insert it, and we can see what the actual driver is doing.  You'd add
> "libertas_debug=0x23" when inserting the 'libertas.ko' module.  That
> will dump info to dmesg, which you should then attach as reply to this
> message.
> 
> Dan


More information about the HostAP mailing list