Hostapd update. Now I have a problem

Jason Carson jason at jasoncarson.ca
Mon Apr 6 11:55:40 EDT 2009


Greetings all,

I set up my wireless access point with the folllowing configuration and it
worked fine for hostapd-0.5.10 but I have just updated to hostapd-0.6.9
and I am running into a problem. I am using the madwifi driver. Here is my
hostapd.conf file...

interface=ath0
bridge=br0
driver=madwifi
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=1
debug=0
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=MyNetwork
macaddr_acl=0
accept_mac_file=/etc/hostapd/hostapd.accept
deny_mac_file=/etc/hostapd/hostapd.deny
auth_algs=1
wpa=1
wpa_passphrase=mypassword
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP


When I try to start hostapd I get the following errors...


penguin ~ # /etc/init.d/hostapd start
* Starting hostapd...
Configuration file: /etc/hostapd/hostapd.conf
ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
Could not connect to kernel driver.
ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
Using interface ath0 with hwaddr 00:19:5b:80:f2:d8 and ssid 'CarsonNet'
                                          [ ok ]


Anyone know what is wrong or what I need to do to fix it?




More information about the HostAP mailing list